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Mapwel softwareMapwel software

Mapwel is mapping software for creation of your own maps and their upload into the GPS unit. Unlike other
software tools that work only with tracks and waypoints, Mapwel allows to create complete maps for GPS. 
Click here to see supported GPS units.

Import of files, files merging Import of files, files merging 
Mapwel supported GPS units require maps in vector format. Therefore, easiest way
of how to create map for GPS is to import files in ESRI *.shp, *.gpx or other vector
format into Mapwel, merge them together and assign proper type to all map
objects. Mapwel also supports import of raster images and their automatic and
manual vectorisation. 

Routable maps with Turn-by-Turn voice navigation Routable maps with Turn-by-Turn voice navigation 
Mapwel supports creation of routable maps (Advanced version only) from
OpenStreetMap *.OSM or cGPSmapper *.MP files. This process is fully automatic in
most cases. It is also possible to draw routable maps manually or convert data from
other sources (ESRI *.shp)  to routable map with little effort. Click here to find out
more. 

Freeware Maps DownloadFreeware Maps Download
Mapwel contains special tool for easy download of large freeware mapsets from
internet and their conversion to routable format. This tool allows to define mapset
parameters and create map tiles automatically. Each map in the set is trimmed and
aligned with other maps for seamless navigation from one map to another. More
>>

Projections and datums Projections and datums 
Imported files in both vector and raster format may use various projections and
geographic systems. Mapwel supports hundreds of the commonly used projections
(including UTM  - Universal Transverse Mercator) and datums. Internal format of
map data in Mapwel is WGS84, because this format is also internal format of the
GPS units. Although user can select various coordinate systems in GPS, coordinates
are always calculated from WGS84 format. Therefore, Mapwel converts all input
data into WGS84. Click here to see list of supported projections. 

Autovectorization Autovectorization 
If you need to get raster image into GPS with just a few mouse clicks, this is the
right tool for you. Mapwel provides Automatic "one-click" vectorisation of raster
images (satellite imagery or scanned maps). Garmin units do not allow to load
raster image directly into the GPS and use it as a map. Therefore, this function
automatically vectorizes raster image and creates vector file compatible with GPS. 
More >> 
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Map Georeferencing Map Georeferencing 
Mapwel provides calibration tool to establish relation between raster image and
map coordinate system. Result is a map with Lat/Lon grid parallel to the screen
edges and coordinates assigned to left, right, top and bottom edge of the map. Click
here to learn more >>
Mapwel also supports OziExplorer *.MAP files and GeoTiff files with included
calibration info. 

User defined styles User defined styles 
GPS units use basic (pre-defined) and user-defined sets of polygon patterns, line
styles and symbol icons. Mapwel provides easy-to-use editor of user styles, which
are supported by most of the new Garmin GPS. Click here to find out more >>

Manual Map Drawing Manual Map Drawing 
Map can be drawn from the scanned paper chart, aerial photos, satellite images
and/or with use of tracks and waypoints imported from your GPS. Tracks and
waypoints are automatically converted into the map elements. Mapwel allows to
draw map with use of straight lines and curves. When drawn with curves, map can
be uploaded into the GPS with chosen precision/data-size ratio. User can apply
Contrast, Brightness and Gamma filters to the scanned chart or satellite image to
adjust the background for convenient drawing of vector objects on the top. To make
drawing of complex objects easier, Mapwel provides Opening in the Area tool. 

ToolsTools
Mapwel tools help to manage maps in your GPS, which are normally not accessible,
or hard to manipulate because they are all merged into a single file. ' Add  maps to
other maps in GPS' function allows to add your map to those already present in the
GPS memory. 'Delete specific maps in GPS' allows to erase individual maps from
your map set. 'Merge IMG files' allows to combines several maps into a single file
for use with Nüvi,  Zümo, Colorado, Oregon or unit, which memory is directly
accessible from Windows.
Other Mapwel tools help to create map faster. For example, 'Create Circle around
Point' function for aviation maps creates 'circles' of defined radius around all
selected points. Very large 'circles' look deformed near poles, because of
coordinate system projection. However, real-world distance from center to any
point on the "circle" is the same. 
Convert Area to transparent grid cell function creates transparent grid from the
polygons. This command converts selected polygons to line objects with label in the
centre of each cell. Text is taken from the polygon's "name".

Freehand Tool Freehand Tool 
Unlike the other Mapwel drawing tools, which are based on the precise manual
placement of the nodes, curves and lines, Freehand tool allows to draw many of the
Mapwel objects very fast with a free hand. Strokes are automatically converted into
the chosen style. After conversion, strokes can be edited as other vector objects
(node by node). 
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Trace Tool Trace Tool 
This is another tool for faster vectorisation of the raster image. It allows to
vectorize one object (or set of similar objects) at once, but it cannot vectorize
whole map with different types of objects at once. Tracing should be repeated for
respective types of objects (filled areas, roads, rivers, etc.). Trace tool works on
images with any common color depth (including True Color and bi-tone) that are
sufficiently clean. 

Object Inspector Object Inspector 
Object Inspector box at right side of the main Mapwel window displays information
about respective map objects and simplifies the object manipulations. It also allows
to select one or several objects in the work space. 

Properties of Objects Properties of Objects 
Each object has adjustable properties like name, comment (text that is displayed in
GPS when cursor stays on top of the object), type, max. zoom level, etc. POI (points
of interest) may have address and phone number assigned. It is also possible to
define properties of the whole map, like name, copyright text, address format,
internal map ID, map draw priority and zoom levels of map layers. 

Automatic Object Splitting Automatic Object Splitting 
GPS rendering engine requires large areas and lines to be split into smaller objects
because of the data structures limitations and speed of map rendering. Mapwel
splits all objects automatically without loss of the map detail when it uploads map
into the GPS. User does not have to bother about the object size or detail
limitations. Splitting process runs internally without user even knowing about it. 

Map Uploading and Export Map Uploading and Export 
Finished map can be saved into Mapwel *.mpw file format, exported into *.img,
*.kml or other supported format, or uploaded directly into the GPS. Export of map
into other than *.mpw file is supported by Mapwel Advanced version only. Mapwel
includes separate MapUpload program for loading *.img files into the GPS.
MapUpload also allows to pack several img files into a single executable file to
distribute to your friends or customers.  

All in OneAll in One
Creation of map for GPS involves drawing or import of map, conversion of data into GPS native format and
upload of data into GPS. Mapwel is the only available software that allows user to do above three steps with a
single software tool. 

• Use Mapwel WYSIWYG workspace to create complete GPS map with filled areas, all types of lines,
map features, cities, exits and points of interest with adresses. Do not limit yourself to just tracks and
waypoints. Use Mapwel import capabilities to open existing maps in various formats. 

• When converting to GPS native format, Mapwel automatically splits large objects to meet GPS
technical requirements and does lot of other automation to make creation of map as easy as
possible. 

• Upload your map directly into the GPS. Mapwel allows you to add your map to other maps already
present in GPS memory. With Advanced version you can even export map into GPS native IMG file. 

• Other most important features include: Free map loader (for IMG files from other sources), Delete
specific maps in GPS function, UTM projected system and many geographic systems support. 
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DemoDemo
 Mapwel is available for download and testing in FREE demo mode. Click herehere to learn about demo
restrictions 

License LevelsLicense Levels
Registered Mapwel software is available in two levels: 

• Basic, for single GPS unit. Basic version allows user to upload map only into the GPS with ID that was
used for registration. This version is intended for personal use. 

• Advanced, for unlimited number of GPS units. Advanced version requires GPS (the one used for
registration) to check validity of password only once after installation of Mapwel. Then user may
attach any other compatible GPS and upload maps into it. This version is intended for personnel or
organizations that own number of GPS units. Advanced version allows to export maps into IMG, KML
and MP format and supports batch conversion mode. 

Registration (Purchase)Registration (Purchase)
To turn demo version into full version without limit user needs to purchase registration password and enter it
into the Mapwel. No additional download is needed. Registration password is derived from the GPS unit ID
number. This number is required for registration. 
When uploading maps into GPS, Mapwel checks the ID of attached GPS. Therefore, GPS with ID used for
registration is needed for uploading maps. Mapwel Advanced (see Advanced version), checks registered GPS
only once, after installation. 

Get StartedGet Started
Click herehere to learn how to make GPS map with Mapwel. 

LimitsLimits
Click herehere to learn about Mapwel limits 

Supported GPS ModelsSupported GPS Models

ModelModel

Garmin™ Nüvifone® M20

Garmin™ Mobile® XT 

Garmin™ Astro® 

Garmin™ Oregon® (all models) 

Garmin™ Dakota® (all models) 

Garmin™ Colorado® (all models) 

Garmin™ Nüvi® and Zümo® (all models) 

Garmin™ Edge 605, 705, 800® 
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Garmin™ iQue M3, M4, M5® 

Garmin™ eTrex Summit HC® 

Garmin™ eTrex Venture Cx, HC® 

Garmin™ eTrex Legend, Legend C, Legend Cx,
Legend HCx® 

Garmin™ eTrex Vista, Vista C, Vista Cx, Vista HCx® 

Garmin™ Rino 120, 130, 520, 530, 520HCx,
530HCx® 

Garmin™ GPS V® 

Garmin™ GPSMAP 60C, 60CS, 60Cx, 60CSx, 62, 62s,
62st® 

Garmin™ GPSMAP 76, 76S, 76C, 76CS, 76Cx, 76CSx,
78, 78s, 78sc® 

Garmin™ GPSMAP 176, 176C, 276C, 376C, 378,
478C® 

Garmin™ GPSMAP 96, 96C, 196, 296, 396, 496® 

Garmin™ Quest, Quest 2® 

Garmin™ Street Pilot i2, i3, i5® 

Garmin™ Street Pilot c320, c330, c340® 

Garmin™ Street Pilot c530, c550, 580® 

Garmin™ Street Pilot 2610, 2620, 2650, 2660® 

 Both serial and USB data transfer is supported. 

 NOTE: Mapwel is not affiliated with any manufacturers mentioned here. All brand names and product names
are trademarks of the respective manufacturers. 
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Mapwel RegistrationMapwel Registration

Mapwel is available in a free demo version for evaluation purposes.

To turn demo into fully-functioning program, user needs to purchase registration password (unlock code) and
insert it into demo main menu / Help / Registration. ID number of GPS is necessary to register. The easiest
way of how to get GPS ID in required form is to use Mapwel demo main menu > GPS > Display GPS IDmain menu > GPS > Display GPS ID.

Depending on the type of purchased password, Mapwel demo switches to BasicBasic or AdvancedAdvanced registered
mode. More details here. 

Sample MapSample Map

To test the map into GPS upload and to see how the finished map looks in
the Mapwel, use the Mapwel_Island.MPW file in the MAPWEL/FILESMAPWEL/FILES
folder. You can upload this map into GPS without truncation even if you
have unregistered version of software. 

Note: map elements like areas, lines and symbols appear gradually as you
zoom-in the map in GPS. Use the Setup/Map/Detail Setup/Map/Detail menu in GPS to set
detail level. 

Mapwel Limits Mapwel Limits 

This chapter is a summary of various limits of mapping with Mapwel software. Some of these limits are
imposed by IMG file format (native format of Garmin GPS units), others are result of GPS firmware, Mapwel
data structures, licence levels, etc.

Map typeMap type
Current version of Mapwel does not support marine maps.

Image sizeImage size
Maximum image size that current version of Mapwel can handle is 30000 x 30000 pixels. However, such
image in raw (uncompressed) form requires large memory space (about 2.7 gigabytes). Moreover, Mapwel
needs about 3-4 times more memory to do operations with image. If you need to work with large images,
please make sure that your computer has enough memory.
Please note: rotation can increase the size of image. Therefore, rotated image can exceed size limit even if
original image fits into the limit

Projections Projections 
Current version of Mapwel supports following projections: 

• Mercator 
• Transverse Mercator 
• Universal Transverse Mercator (UTM) 
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• Lambert Conic Conformal, 1 and 2 standard parallels 
• Oblique Mercator and Hotine Oblique Mercator 
• Oblique Stereographic 
• Albers Equal Area 

Autovectorization - user stylesAutovectorization - user styles
Current version of Mapwel supports max. 86 colors for autovectorization. These colors are represented by
user defined styles (polygons, in this case). Assign different Map Set DataMap Set Data (main menu > File > Properties >
ID tab) to all your maps if they contain user defined styles. This ensures displaying of map with correct colors
in the GPS. GPS uses the same color palette for all maps in a map set. Therefore, maps with different palettes
are not displayed correctly if they have the same Map Set DataMap Set Data.

Supported GPS unitsSupported GPS units
Click here to see list of supported units

OziExplorer Files SupportOziExplorer Files Support
Click here to learn about limits in OziExplorer files support

IMG fileIMG file
IMG file can contain single map or it can contain several maps combined into a single file. Current version of
Mapwel can produce IMG files of max. 17-30 megabytes size, depending on number of text labels (17
megabytes without text labels). This applies to an IMG file that contains single map. Multiple IMG files can be
merged together into a much larger IMG file, which can have hundreds of megabytes or even several
gigabytes. 

Mapwel can handle 20000 cities in the single map. 

Another limiting factor is number of all objects in a single map. The limit is approximately 8 millions of
objects. Some objects must be split (automatically) when exported to IMG file, so the number of objects can
change during conversion. 

AccuracyAccuracy

Map scopeMap scope AccuracyAccuracy

< 45° +-2.4 m 

90° +-4.8 m 

180° +-9.6 m 

Data format of IMG files restricts accuracy of maps. This
restriction is related to the map scope. It means that very large
map is represented in GPS with lower accuracy than the small or
normal size map. Mapwel automatically converts all map data
into the best possible accuracy level. 

Demo Demo 
Mapwel is available for download and testing in FREE demo mode. Demo is fully functional except the limit on
number of objects (map elements) that can be uploaded into the GPS. Therefore, maps uploaded into GPS
with demo are incomplete.  Demo does not truncate autovectorized maps. However, it stamps text 'Mapwel
Demo' to autovectorized maps. Demo version does not support routing. Routable roads are converted to
common roads.

Demo version does not truncate maps if they are located in a 'safe test area' S00.5 - N00.5, W000.5 - E000.5
(WGS84). Place your map within these boundaries to test it in the GPS.
Routing is supported in the safe test area.

Mapwel licence levelsMapwel licence levels
 Registered Mapwel software is available in two levels: 

• Basic, for single GPS unit. Basic version allows user to upload map only into the GPS with ID that was
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used for registration. This version is intended for personal use. Basic version does not allow to export
map into other than *.MPW format. 

• Advanced, for unlimited number of GPS units. However, Advanced version requires one GPS (the one
used for registration) to check validity of password after installation or re-installation of Mapwel. Then
user may attach any other compatible GPS and upload maps into it. User should have registered GPS
by hand when upgrading (re-installing) Mapwel. This version is intended for personnel or
organizations that own number of GPS units. Advanced version allows to export maps into IMG, KML
and MP format and supports batch conversion mode. 

Hardware and software requirements Hardware and software requirements 
• Windows 98/Me, Windows NT/2000/XP, Windows Vista. 
• Minimum hardware requirements: 1 gigabyte RAM, screen resolution 1024x800, True Color display

mode 
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TroubleshootingTroubleshooting

How to use Mapwel with Garmin Mobile XT? How to use Mapwel with Garmin Mobile XT? 
• Connect your phone to computer with USB cable. Select 'mass storage' mode on the phone. After a few

seconds Mapwel should be able to work with the phone like with any other GPS. Try to read GPS ID with
use of Mapwel main menu>GPS>Display GPS ID 

How to use Mapwel with Garmin Nuvifone M20?How to use Mapwel with Garmin Nuvifone M20?
• Access to various controls used in the following text depends on the Nuvifone operating system version

and local settings (language). Therefore, this text does not contain exact step-by-step guide.
• Make sure to set 'Map Detail' in the GPS or Navigation menu of the phone to 'Most'.
• Enable the "Outline Detailed Map" in the same menu.
• Connect your phone to computer with USB cable. Select 'mass storage' mode on the phone. After a few

seconds Mapwel should be able to work with the phone like with any other GPS. Try to read GPS ID with
use of Mapwel main menu>GPS>Display GPS ID 

Map created with Mapwel is not visible on the GPS screen. Map created with Mapwel is not visible on the GPS screen. 
• Most GPS (including Garmin Mobile XT) must be restarted after the map upload. Otherwise, map may be

not visible. 
• If you have problem with map visibility on GPSmap 276C, please click here.
• Some GPS models (like Garmin Mobile XT and Garmin Nuvifone) require to turn on 'Outline Detailed Map'

option in Tools/Settings/Map. Otherwise, border of custom map is not visible and this could make the
searching for a custom map more difficult. 

• Another possible cause of this problem is wrong use of the 'Background Area' polygons. These objects are
intended to define irregular shape of the map. GPS displays only objects that are inside of the Background
Area (if it is present in the map). Other objects are ignored. If Background Area polygon is wrongly used
as a fill of some map object, the whole map is invisible. 

• If you custom Mapwel maps are located on the same place as other detailed maps in GPS and they are
supposed to be displayed one on top of another, the possible cause of map invisibility can be "Draw Map
Priority" parameter. Try to increase "Draw Map Priority" of your Mapwel maps in Mapwel main menu >
File > Properties. 

• GPS does not display maps with identical ID. If you use your own numbering of maps (Mapwel > File >
Properties > ID), each must have a unique internal ID number. Unless you select 'User Defined' option,
Mapwel assigns unique ID number to each map automatically. 

• If you use user defined polygons or polylines, map may be not visible on GPS if it does not support user
defined styles. In such case objects in you map are displayed in blue, yellow or other colors which are not
visible on the map background. In some cases this problem can be solved by upgrading the GPS firmware.
Please visit Garmin web site to find instructions on how to upgrade firmware. 

• Invisibility of map can be caused by wrong map coordinates. If south-north or west-east map scope is too
small, map can be invisible. Please make sure that your map is has least 0.001 degree in both directions. 

• Sometimes user selects wrong coordinate system when importing map and it is positioned on a wrong
place when compared to the real-world location, therefore. Consequently, map uploaded to GPS cannot
be found on expected real-world location and it seems like map is not visible on the GPS. In fact, map is
visible on other place because it is misplaced. Please check if coordinates of the map displayed by Mapwel
match the expected real-world coordinates.

I use custom colors, symbols and fill patterns in my maps and some of themI use custom colors, symbols and fill patterns in my maps and some of them
are displayed in weird colors in the GPSare displayed in weird colors in the GPS  
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• Assign different Map Set DataMap Set Data (main menu > File > Properties > ID tab) to all your maps if they contain
user defined styles. This ensures displaying of map with correct colors in the GPS. GPS uses the same
color palette for all maps in a map set. Therefore, maps with different palettes are not displayed correctly
if they have the same Map Set DataMap Set Data. 

My custom map completely covers the underlaying maps. Is it possible toMy custom map completely covers the underlaying maps. Is it possible to
make them show through my map? make them show through my map? 
• Yes, it is possible. Use Mapwel main menu > Edit > Preferences to turn on the 'Transparent map' option.

Then load the map into the GPS. 

Map in GPS is displayed in other colors than those that are visible in Mapwel Map in GPS is displayed in other colors than those that are visible in Mapwel 
• Map in GPS native format can contain two types of objects: 1. basic, 2. user defined. Objects of basic type

have no color information stored with them. GPS displays them in its own pre-defined colors. User defined
objects have their own color and style assigned by user (Mapwel main menu > Objects > User Defined
Styles). Therefore, you have to use objects from the second category if you want GPS to display them in
your own colors. Moreover, Mapwel allows to draw map objects in the work area in any color to make
creation of map easier. These 'work' colors, however, are not transferred to GPS.  To see how the map
will look like in the GPS, please use 'Color' tab at bottom part of the main Mapwel screen. 

My auto-vectorized map is displayed as a large colored squares and detailsMy auto-vectorized map is displayed as a large colored squares and details
appear only when I zoom in to 120 m appear only when I zoom in to 120 m 
• The most detailed layer of auto-vectorized maps is supposed to appear at higher zoom levels as well.

Check 'Map Detail' setting in your GPS. It should be set to 'Most'. 

Map looks good in Mapwel, but after loading to GPS the polylines and/orMap looks good in Mapwel, but after loading to GPS the polylines and/or
polygons become distorted and look like zig-zag linepolygons become distorted and look like zig-zag line
• The finest coordinate grid used in native map format has approximately 2.5 m spacing. If polylines and

polygons in your map contain large number of very small elements, their coordinates are rounded (some
up and some down) when exported to GPS map format, creating a zig-zag effect. The work around is to
make elements of polylines and polygons longer. 

I try to load map from Mapwel to GPS, but following error message appears:I try to load map from Mapwel to GPS, but following error message appears:
Windows - No Disk Exception Processing Message c0000013 ParametersWindows - No Disk Exception Processing Message c0000013 Parameters
75b6bf7c 4 75b6bf7c 75b6bf7c75b6bf7c 4 75b6bf7c 75b6bf7c
• This error message is supposed to pop-up when there is USB device (GPS, printer, etc.) with a card slot

connected to the computer and there is a false plastic card inserted instead of normal memory card. Try
to disconnect such devices. 

Auto-vectorized raster map is displayed in GPS as a large blue square andAuto-vectorized raster map is displayed in GPS as a large blue square and
there are no details visiblethere are no details visible
• The GPS is probably of old type and its firmware does not support user colors, which are necessary to

display auto-vectorized maps. In most cases upgrade of the unit firmware solves the problem. Please visit
Garmin web site to find instructions on how to upgrade firmware. 

When I import tracks from GPS to Mapwel the long tracks seem to beWhen I import tracks from GPS to Mapwel the long tracks seem to be
truncatedtruncated
• Some GPS units handle tracks in a two different way:
• 1. ACTIVE LOG tracks are exported in full detail.
• 2. Saved tracks are limited to 500 points each. 
• Mapwel does not affect the number of points in the imported track, the truncation is done by GPS when

exporting 'saved' track. 

I have loaded a map into a Garmin Nuvi and when I search on a poi I createdI have loaded a map into a Garmin Nuvi and when I search on a poi I created
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it is not listed. How do I access the custom poi’s I created?it is not listed. How do I access the custom poi’s I created?
• Points from Mapwel map are searchable on Nuvi and similar GPS units only when cursor position (vehicle)

is near (several hundred kilometers or less) the map and points are real POIs (Points of Interest, i.e. not
Map Features). Map Feature points can be converted to POIs with main menu > Convert command. 

I have loaded map into a Garmin Nuvi, but it is looks empty. No objects areI have loaded map into a Garmin Nuvi, but it is looks empty. No objects are
visible.visible.
• If your map contains just points (POIs or Map Features, for example), they appear in Nuvi only at a very

close zoom (about 80m). Mapwel allows to set individual zoom level for each object, but Nuvi firmware
seems to suppress displaying of points, probably in order to make map cleaner and easier to understand
while driving. I would suggest to draw circle with diameter of about 15 meters around each point to allow
to find them on the screen. Select all points and use main menu > Convert > Create Circle around Point
command. 

POIs in my map are not visible on Garmin NuviPOIs in my map are not visible on Garmin Nuvi
•  Please see above. 

Calibration (georeferencing) does not work properly for Universal TransverseCalibration (georeferencing) does not work properly for Universal Transverse
Mercator (UTM). Mapwel puts my map on the northern hemisphere, while itMercator (UTM). Mapwel puts my map on the northern hemisphere, while it
is supposed to be on the southern hemisphere.is supposed to be on the southern hemisphere.
• The problem is in most cases caused by mistaking of UTM latitude band letter and hemisphere designator.

Paper maps use X W V U T S R Q P NX W V U T S R Q P N letters for bands on the northern hemisphere and M L K J H G F EM L K J H G F E
D CD C letters for bands on the southern hemisphere. However, UTM northing coordinates are all measured
from equator, band letters only help to choose proper map sheet, but they have no influence on the
coordinates within the same hemisphere. Therefore, some software programs use only hemisphere
designator (N and S) instead of latitude band letters. For example, UTM 55H on the southern hemisphere
(H stands for lat. band H) from the paper map can be displayed as 55S (S stands for southern
hemisphere) by some software programs. Mapwel uses the lat. band letters, not hemisphere designator.
If S is inserted as lat. band letter by mistake, the map is placed on the northern hemisphere. Solution: in
such case use any lat. band letter from the proper hemisphere. It doesn't matter which one, because
northing coordinates are all measured from the equator. Only hemisphere matters. 

Conversion of existing Mapwel map into routable mapConversion of existing Mapwel map into routable map

Existing map in Mapwel *.MPW format can be converted to routable map so that line objects are converted to
routable roads, their intersections are detected, and some parameters crucial for routable objects are set.
Please follow these steps to accomplish this task:

• When map is loaded into the work area of Mapwel, you have to select all polylines which are supposed to
be roads (main menu > Select > Lines > Roadsmain menu > Select > Lines > Roads) and use main menu > Convert > Convert Linemain menu > Convert > Convert Line
to Routable Road to Routable Road function. 

• Then use main menu > Routing > Detect Intersections main menu > Routing > Detect Intersections function to mark nodes where roads connect
one to another. Now you have map that can be compiled as routable map. 

• The next steps you need to do is to mark border nodes, assign OnewayOneway attribute to respective roads and
define turn restrictions in nodes. Even if you do not define these parameters, the map can be compiled
and will act as routable map in GPS, but navigation will be not 100% accurate because of the missing
information. For example, it will lead you to oneway streets from opposite direction. We do strongly
recommend to set at least the OnewayOneway attribute. 

• Roads ClassRoads Class and Max. SpeedMax. Speed parameters are set automatically during conversion of Lines into Routable
Roads. You may need to adjust these approximate settings for better routing functionality.

Please note: only Advanced version of Mapwel compiles routable map so that it provides turn-by-turn
navigation. Basic or unregistered version compiles routable roads as common lines.
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How to use IMG file from Mapwel with Mapset Toolkit?How to use IMG file from Mapwel with Mapset Toolkit?

• To make map in IMG format exported from Mapwel compatible with Mapset Toolkit, you have to do the
following: 

• Use main menu >File >Properties > Map ID tab to set user defined IDmain menu >File >Properties > Map ID tab to set user defined ID to map. Check 'User
Defined' option and insert some 8 digits map ID number. This number must be unique among all maps in
GPS. Check the 'Use as a file name' option. 

• On the same tab check the 'User Defined' map set data option. Select some Map Family ID and Product
ID. 

• Uncheck 'User Defined Styles' in the map parameters tab'User Defined Styles' in the map parameters tab in the same window to avoid merging of
user styles file to the main map file. If you want to use user defined styles with your map, export styles
into TYP.txt file with use of main menu > Objects > User Defined Styles > Filemain menu > Objects > User Defined Styles > File. 

• Make sure that map has 'Background Area' object'Background Area' object which defines the shape of the map. If there is no
such object, draw it manually. It can have irregular shape or it can be just rectangle. 

• Export map into IMG fileExport map into IMG file format. 
• Load IMG file to Mapset Toolkit. Load TYP.txt file into respective box. Previous steps were made to ensure

compatibility with Mapset Toolkit, which should be achieved at this point. 
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TutorialsTutorials

How to acquire GPS ID numberHow to acquire GPS ID number

Use the main menu > GPS > Display GPS IDmain menu > GPS > Display GPS ID command. 

Mapwel displays GPS ID in a specific way, with checksum of all previous digits. 

For example ID 32043123 is displayed as 32043123_18 where 18 is 3+2+0+4+3+1+2+3. The checksum helps
to avoid typographical errors in GPS ID when purchasing Mapwel licence. 

How to load raster image into GPSHow to load raster image into GPS

Automatic VectorizationAutomatic Vectorization

(Sample file in *.IMG format is stored in MAPWEL>FILES folder.)(Sample file in *.IMG format is stored in MAPWEL>FILES folder.)

This function can be accessed via main menu > Image > Automatic Vectorizationmain menu > Image > Automatic Vectorization. It allows to create
map for GPS from satellite images or scans automatically, within a few minutes. It is intended for use in
situation when there are no vector maps available of the area of interest, and drawing of precise vector map
is not efficient either because of lack of time or limited use of the map.

In fact, Garmin units do not allow to load raster image into GPS and use it as a map. This function
automatically vectorizes raster image and creates vector file compatible with GPS. Autovectorized maps
contain thousands of small color spots and are large is size and slow to render on GPS, therefore.

Objects automatically vectorized from raster image.
Map consists of large number of polygons.

Colors are derived from raster and included into "User defined styles" 
for optional manual tuning and/or transfer to other map file.

Examples of autovectorized maps in GPSExamples of autovectorized maps in GPS
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Pros:Pros: almost "one-click" process to create ready-to-use GPS map. You can create map like above examples in
a few minutes. Auto-vectorized map can be combined with waypoints, tracks, manually drawn objects or
other map data (like merged shapefiles, etc.)

Cons:Cons: GPS must support user defined styles (most of new units support them). Auto-vectorized map file is
larger than normal map file and its rendering in GPS is slower. Auto-vectorized map does not allow to search
objects. Objects do not have names, hints and other attributes. In other words, this kind of map is for viewing
only.

Technical notesTechnical notes

• Auto-vectorized maps were successfully tested on Colorado, Nuvi, GPSMAP 60CSx, Street Pilot c550.
• Number of auto-vectorized maps can be loaded into GPS at once. Auto-vectorized maps can be exported

into IMG format and combined with any other GPS maps. Current version of Mapwel supports max. 86
colors for autovectorization.

• Assign different Map Set DataMap Set Data to all auto-vectorized maps you create. This ensures displaying of map
with correct colors in the GPS. GPS uses the same color palette for all maps in a map set. Therefore,
maps with different palettes are not displayed correctly if they have the same Map Set DataMap Set Data.

• Warning: you have to set map detail in GPS to 'Most' (default value is 'Normal') to see autovectorized map
in full detail. Otherwise, only a large colored squares are visible. Autovectorized map is supposed to be
rendered in full detail at zoom 800 m and closer.
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Map setup menu with Detail option.
This is screenshot from Colorado 300, but each Garmin GPS has some menu for setting this option.

Make sure to set it to 'Most'. 

How to use auto-vectorizationHow to use auto-vectorization

• Use any image editing software to resample and crop raster image. Reduce number of colors to fit into
range supported by Mapwel (up to 86).  Save image into GIF, PNG or BMP  format (do not use JPG
because it does not preserve exact color palette).

• Import image into Mapwel. If number of colors exceeds max. allowed number, Mapwel automatically
reduces number of colors during autovectorization.

• Calibrate the image. You can skip this step if you import OziExplorer callibrated image or GeoTiff image.
• Use main menu>Image>Automatic Vectorization function to create map.
• Send map from Mapwel to GPS.

How to reduce number of colors in an imageHow to reduce number of colors in an image

To use image for automatic conversion into vectors, you may need to reduce number of colors. Mapwel
reduces number of colors automatically, but you may need to use the same color palette for several images.
In such a case, reduce colors manually, save the color palette and use it for other images too. 
Following short tutorial explains color reduction in Photoshop and in GIMP (free program for image
manipulation).
If you have Adobe Photoshop, you can use following approach:

1. Use Photoshop > main menu > Image > Mode > Indexed Color to open window for color reduction.    
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2. Select no dither, no transparency and set required number of colors Select any type of palette that works
best for your image.    

  

3. Image with reduced number of colors lacks blue color for pool. We will add it manually. Undo the color
reduction and repeat step 1. However, select 'Custom' palette in this case. 
Please note: in this simple example number of colors is reduced to 9, but Mapwel supports much more colors.
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4. Custom palette contains 9 color automatically selected in previous color reduction. Add light blue color as
10th color into palette and click OK. Image now contains 10 colors and light blue is among them. Save image
into BMP, GIF or PNG format to avoid colors distortion (do not use JPG format for the same reason).   

   

Color reduction in GIMPColor reduction in GIMP

In GIMP, please use 3 simple steps illustrated on below pictures (thanks Greg). GIMP is a free program for
image manipulation. Installation files for Windows are a available from http://gimp-win.sourceforge.net
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Image with large number of colors.

Select image > mode > indexed to reduce colors.

Choose number of colors.
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Sample file in *.IMG format is stored in MAPWEL>FILES folder.
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How to make your own mapHow to make your own map

Garmin GPS units accept only vector data. Therefore, creation of map in Mapwel involves several steps from
calibration of raster scan or satellite image to upload of vectorized map to GPS. It is also possible to import
vector data from various file formats and sources. Since version 2009, build 6.6, Mapwel supports creation of 
routable maps with turn-by-turn navigation. 
To get started with drawing of simple map, please click on any below step to see simple example: 

1. Image calibration
2. Background filters (colors)
3. Drawing/import of objects
4. Upload of map into GPS

Raster files used in above examples are mw.jpg and mw2.jpg. They can be found in MAPWEL > FILESMAPWEL > FILES
folder. 
Some of these steps are not necessary if your input data are already vectorized and stored in a file format
supported by Mapwel (ESRI shapefiles, OSM, GPX, MP, KML, KMZ) or if they are already georeferenced.
Please see the following table for steps needed when working from a specific data source: 

Working fromWorking from
scan, aerial orscan, aerial or
satellite imagesatellite image
(raster image)(raster image)

Working fromWorking from
georeferencedgeoreferenced
imageimage
(OziExplorer or(OziExplorer or
GeoTiff file)GeoTiff file)

Working fromWorking from
vector file (ESRIvector file (ESRI
shapefiles, MP,shapefiles, MP,
OSM, GPX files)OSM, GPX files)

Image calibrationImage calibration

BackgroundBackground
filters filters optional optional

Drawing ofDrawing of
objectsobjects optional

Upload of mapUpload of map
into GPSinto GPS

Only the most frequently used methods are shown in above table. Each of them can be combined with use of
your own tracks and waypoints imported from GPS, map files in OSMOSM or GPXGPX format downloaded from
internet, etc. 

There are several ways how to create vector objects for the map There are several ways how to create vector objects for the map 
• Manual drawing of objectsdrawing of objects
• Automatic vectorization of whole raster imagevectorization of whole raster image
• Automatic tracing of objects from raster imagetracing of objects from raster image
• Freehand drawingFreehand drawing with mouse or tablet 
• Import of tracks and waypoints from GPStracks and waypoints from GPS 
• Use of ESRI shapefilesESRI shapefiles
• Use of OpenStreetMap *.OSM filesOpenStreetMap *.OSM files
• Merging of other Mapwel files or other compatible files (*.MP, *.OSM, *.GPX, *.KML, *KMZ, etc.) 

Routable maps (maps with spoken turn-by-turn navigation)Routable maps (maps with spoken turn-by-turn navigation)
• Conversion of existing map into routable mapConversion of existing map into routable map
• Manual drawing (vectorization) of routable roadsManual drawing (vectorization) of routable roads
• Import from OpenStreetMap *.OSM or cGPSmapper *.MP fileOpenStreetMap *.OSM or cGPSmapper *.MP file
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• Import from ESRI shapefilesESRI shapefiles

Options to manage maps in your GPS Options to manage maps in your GPS 
• Erase specific mapErase specific map in GPS 
• Add map to maps already present in GPS 

In case of problems with map uploading or displaying on GPS, please click hereclick here. 

Raster Image Calibration and Georeferencing Raster Image Calibration and Georeferencing 

Mapwel provides calibration tools to establish relation between raster image and map coordinate system.
Result is a map with Lat/Lon grid in WGS 84 parallel to the screen edges and coordinates assigned to left,
right, top and bottom edge of the map. In some cases, distorted image (scan) or image representing map
with unknown projection must be edited with special non-linear tools prior to calibration.

CalibrationCalibration
transforms raster image and vector data drawn on top of the image to the Lat/Lon
grid parallel to the screen edges. This method uses an affine linear transformation
and least squares method and will work with maps which are rotated or skewed.
The Lat/Lon grid of the image must be linear (straight lines) to allow linear
transformation to the grid parallel to screen edges.  Even images with a non-linear
Lat/Lon grid can be calibrated with this tool, if the grid non-linearity is caused by
projection (like UTM, for example). In such a case, map usually contains linear
Easting/Northing grid and non-linear Lat/Lon grid. Calibrate map with use of the
Easting/Northing grid and Mapwel recalculates image so that the Lat/Lon grid
becomes linear. 

Optional linear and non-linear raster image editingOptional linear and non-linear raster image editing
involves separate transformation of raster image into rectangular grid. If image
(typically distorted scan or map with unknown projection) is curved in a way that
direct calibration cannot be used, it can be edited with tools for rotation, move,
cropping and non-linear straightening. The goal is to achieve linear Lat/Lon grid.
Then the image can be calibrated. If calibrated image does not match the tracks
and waypoints imported from GPS, non-linear morphing can be used to stretch
image locally to proper position. Use of the non-linear editing tools is not
recommended and should be avoided whenever it is possible, because it can lead
to wrong georeferencing. 

Image EditingImage Editing

Mapwel provides several tools for image editing. This chapter deals with image rotation, cropping and
straightening. Editing of raster image is an alternative approach to calibration. Click here for more image
editing and calibration tools. 

  To rotate, straighten and crop image use following approach:To rotate, straighten and crop image use following approach:

 1. Use main menu > Image > Import function to place image into the work area background. Scanned photo
is usually rotated and distorted. 

Mapwel 2010 7.1 Manual

26



 2. Use main menu > Image > Rotate to Horizontal function to rotate the image. Place the rotation marks on a
line that is supposed to be horizontal. Then click right mouse button and choose Rotate Image command from
the pop-up menu. 

 3. Image is rotated so that marked grid line is horizontal now. 
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4. Use the main menu > Image > Straighten function to compensate the image deformity. The tool that
appears in the work area has two main marks (left top and bottom right corner) and 6 additional marks. 

 5. Place two main marks on map corners first. Then move the rest of marks to a corresponding spots on the
map edge. The black dashed rectangle indicates how the map will be straighten. Click right mouse button and
then choose Straighten Image command from the pop-up menu. 
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6. Use main menu > Image > Crop function to eliminate the empty space around the map. Place the crop
marks and then click right mouse button to access the pop-up menu. Click on Crop ImageCrop Image item. 

7. Adjustment of image is finished. 

Mapwel 2010 7.1 Manual

29



Background Filters (Colors)Background Filters (Colors)

When using imported image as a template for map drawing, it can be useful to make it brighter, darker or
less saturated to allow objects drawn on the top to be more visible and thus make the work more
comfortable. 

  Use the main menu > Image > Background Filters window to adjust brightness or colors saturation. In this
case the GammaGamma parameter was adjusted to make image brighter. 
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  Background image is much brighter, while all detail is still visible. 

Drawing of ObjectsDrawing of Objects

Vector data from which the GPS map is made include: 
- Areas (polygons)
- Lines (polylines)
- Points (Points of Interest, Cities, Exits, Map Features) 

Some area types (Park) are always displayed beneath others, regardless on their creation order. Therefore, it
is necessary to ensure that no other area covers them. 

Areas should overlap each other a bit to avoid of displaying a small gap between the areas in GPS. 

Mapwel 2010 7.1 Manual

31



1. Areas1. Areas
Let's draw the ocean area first. As the map is supposed to be rectangular in this case, the edges of ocean

area should lie exactly on the Work Area edges. Select the Area toolArea tool  and place the first node
somewhere near the bottom left corner of the Work Area. Set the edge type to straight lines (control 1).
Check the 'Snap to Work Area Edges' option (2). Set the object parameters name (3) and type (4). Draw the
ocean object by clicking left mouse button on the Work Area. Select each of the nodes (5) and move it
towards the Work Area corner. As the 'Snap' 'Snap' option is ON, the nodes will be snapped to the corners
automatically. Then click the right mouse button and choose the Finish ObjectFinish Object command from the pop-up
menu. 

The ocean area now covers whole map. It is of an orange color, because this color was set in the Palette.
Note that new object is displayed in the Object Inspector window as a small icon. 

Now we will draw an opening for the ocean area to create a hole for the forest object to show through. Select

the Opening toolOpening tool  and draw the hole. After placing the first node, change the edge type to curves. The
future forest object should overlap the ocean and land objects (because forest is displayed beneath all other
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objects), while the ocean object should overlap the land (because land will be on top of other areas). This is
the reason why the opening is draw on the edge of the forest (1) and why it overlaps the land (2). See below
animated example on how to draw area or opening with curves.

 Animated image. Animated image.

Now there is the opening in the ocean object. Note that combined ocean+opening object is displayed in the
object inspector window. Separate parts are displayed in the Parts window to allow user to select and
manipulate them. 

     

To change color of the ocean object, press left mouse button on the color in the Palette and draw color to
object icon in the Object Inspector or to the selected object in the Work Area. Then release the button. 
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Another way is to click right mouse button on selected object and choose Color command from the pop-up
menu to access the color dialog window. 

     

Now we will draw the second area - forest. Select the Area tool and draw the forest object with use of
curves. Note that forest should overlap all other areas (ocean and land), because it is displayed beneath them.
While drawing the forest, set the area type to Park. Note the 3rd icon in the Park item which indicates that this
object is displayed beneath others. 

  The forest area is finished. Now there are two objects in the Object Inspector window. 
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We will draw the 3rd type of area - land. Use the same approach as with the forest with a single difference -
the land area is on top of others and therefore you do not have to make overlays. There are 5 land areas in
this example. 

2. Lines2. Lines

Now we will draw the lines (land contours). Select the Line toolLine tool and draw all contours one-by-one with
use of the curves. See below animated example on how to draw line objects.

 Animated image. Animated image.

When lines are finished, select them all and click right mouse button on selection to access the pop-up menu.
Choose PropertiesProperties to open Properties window and set Land Contour line type. 
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The map looks like this now.  Note that when you move cursor over the object icon in the Object Inspector
window, enlarged object icon and its description is displayed in the zoom window. 

3. Symbols3. Symbols
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Select the Map Feature toolMap Feature tool  and click on the respective spot on the map to place the symbol. Default
type of map feature is Summit, therefore only the object name should be changed, in the case. Select the
object and click right mouse button to access the pop-up menu. Choose PropertiesProperties and set the object's
name in the Properties window. 

    Now make the rest of symbols in the map. They are Map Features objects too. Select the Navaid>RaconNavaid>Racon
type in the Properties window after object is finished. 
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Duplicate the Racon symbol and place it on the proper spot on the map. This simple example map is finished
now. To check how it will look like in the color or monochrome display GPS click on 'Color''Color' or 'Grey Scale''Grey Scale'
tabs in the bottom left corner of the Mapwel. You can switch between the tabs anytime during the map
creation. 
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Upload of Map into GPSUpload of Map into GPS

This function can be accessed via main menu > File > Upload Map to GPSmain menu > File > Upload Map to GPS.

User can upload one or several maps into the GPS unit. Mapwel uses unique GPS ID set by GPS manufacturer
to check the registration before the map upload. Therefore, user is prompted to attach the GPS that was used
for purchase of registration password.

If Mapwel is in AdvancedAdvanced version, user can disconnect the registration GPS and attach any compatible GPS
for map upload. Basic Mapwel version allows user to upload only to single GPS unit. Unregistered Mapwel
allows user to upload map to any compatible GPS, but map is truncated.

If you want to transfer several maps into the GPS at once, add maps to the map list. Use the main menu or
pop-up menu (accessible with right mouse button click on the list) to manage the list items.

Geographic location of files transferred to GPS is plotted on the world map, for reference.

Current Map denotes map currently open in the Mapwel. Add to existing maps option allows to add your map
to maps already loaded in the GPS.

Important: Important: if your GPS is connected to PC via serial port, please make certain that Serial Data Format in
Setup / Interfaces in the GPS is set to "GARMIN". 

The map should only be uploaded to the unit for which it is intended. If this map is uploaded to a GPS unit
other than it is designed for, it will render the unit inoperative Do not operate the GPS unit during the transfer!
Click herehere to see list of supported GPS models.

In case of problems with map uploading or displaying on GPS, please click herehere.
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Raster Image Calibration and GeoreferencingRaster Image Calibration and Georeferencing

Mapwel provides calibration tools to establish relation between raster image and map coordinate system.
Result is a map with Lat/Lon grid in WGS 84 parallel to the screen edges and coordinates assigned to left,
right, top and bottom edge of the map. In some cases, distorted image (scan) or image representing map
with unknown projection must be edited with special non-linear tools prior to calibration. 

CalibrationCalibration
transforms raster image and vector data drawn on top of the image to the Lat/Lon
grid parallel to the screen edges. This method uses an affine linear transformation
and least squares method and will work with maps which are rotated or skewed.
The Lat/Lon grid of the image must be linear (straight lines) to allow linear
transformation to the grid parallel to screen edges.  Even images with a non-linear
Lat/Lon grid can be calibrated with this tool, if the grid non-linearity is caused by
projection (like UTM, for example). In such a case, map usually contains linear
Easting/Northing grid and non-linear Lat/Lon grid. Calibrate mapCalibrate map with use of the
Easting/Northing grid and Mapwel recalculates image so that the Lat/Lon grid
becomes linear. 

Optional linear and non-linear raster image editingOptional linear and non-linear raster image editing
involves separate transformation of raster image into rectangular grid. If image
(typically distorted scan or map with unknown projection) is curved in a way that
direct calibration cannot be used, it can be edited with tools for rotation, move,
cropping and non-linear straightening. The goal is to achieve linear Lat/Lon grid.
Then the image can be calibratedcalibrated. If calibrated image does not match the tracks
and waypoints imported from GPS, non-linear morphing can be used to stretch
image locally to proper position. Use of the non-linear editing tools is not
recommended and should be avoided whenever it is possible, because it can lead
to wrong georeferencing. 

How to Calibrate ImageHow to Calibrate Image

Click Click herehere for more image editing and calibration tools.  for more image editing and calibration tools. 

This tool is available via main menu> Image > Calibrationmain menu> Image > Calibration. It allows to transform raster image and vector
data drawn on top of the image to the Lat/Lon grid parallel to the screen edges. This method uses an affine
linear transformation and will work with maps which are rotated or skewed. The Lat/Lon grid of the image
must be linear (straight lines) to allow linear transformation to the grid parallel to screen edges.  Even images
with a non-linear Lat/Lon grid can be calibrated with this tool, if the grid non-linearity is caused by projection
(like UTM, for example). In such a case, map usually contains linear Easting/Northing grid and non-linear
Lat/Lon grid. Map should be calibrated with use of the Easting/Northing grid and Mapwel recalculates images
so that the Lat/Lon grid becomes linear.

Click herehere to see list of supported map projections.

Image with projection and grid linesImage with projection and grid lines

Below map is in UTM coordinates and has 2 grids: Lat/Lon grid (highlighted with blue color), which is curved
because of the projection, and Easting/Northing grid (highlighted with red color), which is linear. Calibration
and conversion from UTM to Lat/Lon will make the Lat/Lon grid linear and parallel with the screen edges.
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Left: non-linear Lat/Lon grid. Right: linear UTM grid.

Use main menu> Image > Calibrationmain menu> Image > Calibration to start the calibration tool. We will use 3 points with UTM
coordinates to calibrate the image. As the grid lines are drawn on the map, the easiest way is to position
calibration points on intersections of the grid lines. Current version of Mapwel allows to use up to 6 calibration
points. While 3 points are necessary to define affine transformation matrix, 4th, 5th and 6th points
overdetermine the system and can help to increase accuracy of calibration.
   

   

Left: image with calibration points positioned on intersections of grid lines. Right: detail.

Panel at the right side of the Mapwel screen contains calibration controls. They should be used in the following
way:

• Select any calibration point by clicking on the respective tab (1). Selected point is highlighted in the work
area and automatically scrolled into center of the screen (if there is enough space to scroll). Number of
calibration points is defined in combo box above the tabs.

• It is possible to use any of the snap node options to snap calibration points to nodes, objects, etc. It is
often convenient to snap calibration points to waypoints or guide lines placed on the map.

• Define geographical position of each calibration point by clicking on the coordinates (3) and typing exact
coordinate values into boxes (6) in window that appears. Select projection (4), if any, and Datum (5). In
this case, coordinates are defined as easting and northing, in meters. Click OK button (7) to close the
coordinates window.
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Left: Window for entering point coordinates in various systems. Right: panel with calibration controls.

When geographical position of all calibration points is defined, click ApplyApply button at top of the Mapwel screen,
or use right mouse button click to invoke pop-up menu in the work area. Then select ApplyApply command from
the pop-up menu. Image is calibrated so that Lat/Lon grid becomes linear (see blue grid on the below image)
and coordinates of the map are derived from the geographical position of the calibration points. Below map
coordinates are in WGS84.

Calibrated image.

Overall map coordinates in WGS84, derived from the calibration points
.

NotesNotes

• When using 2 points calibration, the points can be placed anywhere on the map, but the best precision is
achieved when 2 points are as far one from the other as possible. Points cannot be placed on the vertical
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or horizontal line, i.e. they cannot have any coordinate identical.
• When using 3 points calibration, the points can be placed anywhere on the map, but the best precision is

achieved when 3 points are as far one from the other as possible. Points cannot be placed on the same
straight line in any direction.

• 4,5 and 6 points calibration uses the same method as 3 points calibration, but transformation data are
calculated as best match for all points, so it can provide better precision than 3 points case. 

• All calibration points must be specified the same coordinate system, i.e. do not change projection and/or
datum when entering next point. However, if map is projected, calibration points can have different grid
codes, i.e. they can span several grid cells.

• If image does not contain grid lines, it is recommended to use some distinctive points like crossroads.
Their coordinates can be easily found with Google Earth, for example. Another way is to measure
coordinates of these points with GPS.

• Map without projection is calibrated in the same way as above map, but "Projection""Projection" option should be
disabled. Coordinates are entered in Lat/Lon form.

• When converting UTM coordinates to Lat/Lon, Latitude Band LetterLatitude Band Letter affects only selection of the
hemisphere (north and south). Therefore, you may get the same Lat/Lon coordinates with different UTM
Latitude Band Letters.

Import of ESRI Shape FilesImport of ESRI Shape Files

ESRI Shape Files ESRI Shape Files are vector files that contain geographical data and optional attributes. Shape files can
support point, line and area features. Each layer is stored separately. An ESRI shape file consists of main
file (.SHP), an index file (.SHX) and attributes dBASE table (.DBF). 

Use the main menu / File / Open or Mergemain menu / File / Open or Merge function to import an ESRI shape file and convert it into the
Mapwel map. Then you can upload it into the GPS unit or export into other format (Advanced version only). 

As the shape files are primarily not designed to use with GPS units and attributes of objects are specified by
user, Mapwel cannot assign the shape file attributes (data) to the map object properties like Name,
Comment, Type, etc. automatically. User is prompted to assign available shape file data to the map
objects. 

Because layers are stored in a separate shape files, it is necessary to Merge Merge (with use of main
menu>File>Merge command) all shape files to create complete map in Mapwel. Mapwel stores whole map
in a single MPW file. 

Loading of each SHP file involves following steps:Loading of each SHP file involves following steps:

1. Coordinate System.Coordinate System. Selection of projection and datum used for representation of geographical
data in SHP file. 

2. Types.Types. Assignment of SHP attributes to types (like polyline type) used by Mapwel and Garmin GPS. 
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3. Enumerated Parameters.Enumerated Parameters. Assignment of SHP attributes to object parameters with limited
number of allowed values (like "Oneway" road parameter) in Mapwel. 

4. Parameters.Parameters. Assignment of other SHP attributes representing name, comment, street name,
phone number and other data to Mapwel data structures. 

5. Format.Format. Formatting of object name, comment. Selection of elevation units, etc. 

Only the first step (selection of coordinate system) is obligatory. Next steps are optional, but they are useful
to transfer information from attributes in  a shapefile to objects in Mapwel. This helps to reduce or
completely eliminate editing of map in Mapwel. 

Step 1 - Selection of projection and datumStep 1 - Selection of projection and datum

Use the first tab in the SHP open file dialog to select coordinate system of the SHP file. This is the most
important step in loading of the shapefile. You have to know coordinate system of the SHP file. If chosen
coordinate system is not the right one, map will be imported improperly. This information is often stored in
*.PRJ text file enclosed to the shapefiles. If *.PRJ file is in the same folder as *.SHP file and has the same
name, Mapwel tries to read the georeference data automatically. 

UTM Zone NumberUTM Zone Number, UTM Latitude Band LetterUTM Latitude Band Letter and Planar Distance Units Planar Distance Units are controls for definition of
additional information for UTM system. UTM Latitude band letter affects only selection of the hemisphere
(northern or southern) when converting coordinates from UTM to Lat/Lon. Therefore, you can obtain the
same Lat/Lon coordinates for various band letters. 

Use Data Size Reduction Data Size Reduction control to decrease the number of imported vertices (in case of area and line
objects). If imported data contain too many vertices, displaying of map on the GPS can be very slow. In such
a case, reduce the size of imported data to speed-up the map displaying. Reduction of vertices decreases
also precision of the map elements definition. The highest available accuracy of the map elements uploaded
into the Garmin GPS is approximately ±1.2 m. Accuracy of imported data should be lower or equal to this
value to optimize the speed of map displaying and data size. 

Border Border is an empty space added around the map. Imported map may be clipped to bounding rectangle of
all objects. Set Border to non-zero value if you need to add empty space around the map. Click left or right
mouse button on the value to increase/decrease it, or click on 'Border' label to set value by keyboard. 

Click the Next>>Next>> button when you are finished with selection of coordinate system and data size
reduction. 
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To learn about custom (user-defined) projections, click hereclick here please. 

Step 2 - Assignment of attributes to Mapwel typesStep 2 - Assignment of attributes to Mapwel types

If any of the SHP file attributes defines the type of objects, you can use this tab to create
attribute-to-Mapwel type conversion table. 

Mapwel cannot recognize meaning of SHP attributes automatically, as they may contain any type of
information. Definition of conversion table allows user to assign proper type to imported objects. 

You can skip this step if: 

• there is no attribute that defines type of objects 
• some attribute already contains Garmin object types 
• you do not wish to assign type to objects. 

Use Import roads as routableImport roads as routable option to convert polylines that represent roads to Routable road Routable road objects
in Mapwel. Other polylines (like rivers, power line, etc.) are converted to common LineLine object. It is possible
to make such conversion later in the work area of Mapwel as well. However, next tabs allow to assign
parameters essential for routing only when this option is checked. 

If Detect intersection nodesDetect intersection nodes option is checked, program will automatically detect and mark intersections
of routable roads. These intersection nodes are essential for compilation of routable map. Detection of
intersection nodes can be done also later, with use of main menu > Routing > Detect Intersections
command. 
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Follow these steps to create conversion table: Follow these steps to create conversion table: 

A) Select attribute that defines the object types. 

B) Click on the first line of the first column in conversion table. Select attribute value from the pop-up menu
that appears. 
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C) Click on the second column in the same line. Select type of object from the pop-up menu. This type will
be assigned to all imported objects that have attribute ROADCLASSROADCLASS set to value PrimaryPrimary
. 

D) Use Add Add button to create as many items in the table as necessary. Define all attribute value - object type
pairs. 

When finished, click on the Next Next >> button. 

Step 3 - Assignment of attributes to Mapwel typesStep 3 - Assignment of attributes to Mapwel types

You can use this tab to create 'attribute value-to-Mapwel parameter value' conversion table. This table
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contains only parameters with finite number of possible values, for example 'Oneway' parameter, which can
be only TRUE (checked) or FALSE (unchecked). Shapefile attribute value is mapped to the Mapwel
parameter value. 

The first column contains such parameters and all their possible values, for example: Max. Speed:10 km/h,
Max. Speed: 20 km/h, etc. It is not possible to edit this column. However, user can select shapefile attribute
into the next column and its value to 3rd or 4th column. In below example Max. SpeedMax. Speed is set to 130 km/h130 km/h
in Mapwel for all objects that have TYPETYPE attribute set to HWY HWY in the shapefile. 

Selection of attribute or its value is easy: just click on respective table cell and select required item from the
pop-up menu that appears. You should define the attribute first and the value(s) next, because values list is
generated according to selected attribute. It is not necessary to fill-in all cells in the table. Set only those
lines of table that you need to. 

Shapefile can contain any attributes with any values and this table allows to map them onto parameters of
individual objects in Mapwel. There are two columns (Value 1 and Value 2) of attribute values for case that
you need to map two attribute values to the same Mapwel parameter value. For example, you may need to
map TYPE: TRAIL and TYPE: WALK from shapefile to the same Mapwel parameter value Max. Speed: 10
km/h. Note: speed levels are set to km/h or mi/h according to units selected in main menu > Edit >
Preferences
. 

Step 4 - Assignment of other SHP attributes to Mapwel data structuresStep 4 - Assignment of other SHP attributes to Mapwel data structures

The fourth tab allows to assign attributes with virtually infinite number of values (like text labels, for
example) to Mapwel object. 
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If there are attributes, which define the name, comment or other Mapwel-compatible data like street name
or phone number, use this tab to assign them to the respective Mapwel variables. 

If imported file has an attribute that conforms the Garmin polygon, polyline and point indexing system, 
assign this attribute to the Type Type variable. This condition is usually satisfied by shape files originally created
for GPSmapper software. 

If type conversion table was defined in Step 2Step 2, Type Type is automatically set to the respective attribute. 

Left SideLeft Side and Right Side Right Side controls allow to define house numbering along the street for the Routable Road
objects. Type of numbering (None, Even, Odd or All) can be set on the previous tab. 

Step 5 - Fields formattingStep 5 - Fields formatting

Mapwel 2010 7.1 Manual

49



Click the FinishFinish button when the last step is finished. 

In this case, imported map has four types of lines: 3 types as defined in the Step 2Step 2 and the 4th (default)
type for rest of the lines, which were left with the undefined type. 

OpenStreetMap (*.osm) file format supportOpenStreetMap (*.osm) file format support

OSM filesOSM files are great free-of-charge source of detailed maps. They are available at
http://www.openstreetmap.org/index.html.

"OpenStreetMap creates and provides free geographic data such as street maps to anyone who wants them.
The project was started because most maps you think of as free actually have legal or technical restrictions
on their use, holding back people from using them in creative, productive, or unexpected ways." 

Mapwel allows to upload OSM filesOSM files into the Garmin GPSGarmin GPS units with just a few clicks of mouse, preserving as
much of visual similarity as possible. OSM files specification includes number of polygons, lines and icons.
Most of them are not supported by Garmin basic set of objects. However, Mapwel contains library of special
pre-defined styles to render OSM maps on Garmin GPS correctly. 

Mapwel imports OSM file so that roads are automatically converted to routable roads with turn-by-turn voice
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navigation.

There are two special road types: Roundabout and Ramp for which GPS generates a special navigation
instructions. Mapwel identifies these road types automatically when importing map from OSM file. It is also
possible to convert road to any of these types manually with use of the Properties window.

 The steps needed to get OSM map into Garmin GPS are simple: 

• Download OSM file of respective area from http://www.openstreetmap.org/index.html
• Open OSM file in Mapwel. If you want to combine several OSM files, use Merge function for rest

of the files. 
• Click 'Upload map to GPS''Upload map to GPS' button in Mapwel to load map to the GPS unit. 

Please note:Please note: above instructions refer to download of individual OSM files of small size. For automated
download of large map sets please use main menu >Tools > Download Free Mapsmain menu >Tools > Download Free Maps command.

To download OSM file from http://www.openstreetmap.org/index.html, browse area of interest and click on
the Export tab (see below image). Then select 'OpenStreetMap XML Data' 'OpenStreetMap XML Data' option from the left panel. Then
click Export button. Store *.osm file into any folder of your computer. 

Open *.osm file in Mapwel. You can edit it, combine with other vector maps, waypoints, tracks, etc. When
finished, upload map to GPS with use of 'Upload map to GPS' 'Upload map to GPS' button. Map in GPS looks like below examples.
Please note: your GPS must support user-defined styles. All new Garmin GPS support them. If you have older
GPS, you may need to upgrade its firmware to render map correctly. 
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OpenStreetMap on Garmin GPS. Compiled and uploaded with Mapwel. Some colors and icons are from
Mapwel pre-defined styles.  

Download Free Maps (OpenStreetMap files)Download Free Maps (OpenStreetMap files)

This tool is accessible via main menu > Tools > Download Free Mapsmain menu > Tools > Download Free Maps command. It allows to download
large freeware maps and converts them into routable files for GPS with just few clicks of mouse. PleasePlease
note: this tool works only if your computer is connected to internet. Routing is supported onlynote: this tool works only if your computer is connected to internet. Routing is supported only
by Advanced version of Mapwel. by Advanced version of Mapwel. This tool is supposed to be used with Advanced version of Mapwel. Maps
downloaded with unregistered or Basic version of Mapwel are usable in GPS, but they are marked with 'Trial
Map' labels and they are not routable.

OpenStreetMap OSM files can be downloaded individually from respective www address. Mapwel allows
conversion of these files into routable maps for Garmin GPS units. However, downloading and processing of
large number of maps can be very time-demanding process, because each map must be cropped and aligned
with other maps to ensure seamless navigation. Following tool allows to select large area on the world map,
split it into individual maps and convert all maps as a map set for Garmin GPS. 

To prevent confusion when using terms "map" and "map set" frequently, this tool uses term "tile""tile" for
individual map and "set""set" for set of map. 

SetSet

Internal data structure of map file and GPS rendering engine limit the size of individual maps (tiles).
Therefore, large maps are always composed of smaller maps. These small maps are organized into so called
"sets". Maps in the set share the same color palette, user-defined icons and few other parameters.
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How to Construct Set of TilesHow to Construct Set of Tiles

Your map set can contain one or multiple tile. Each tile in the set must have its own bounding rectangle
(current version supports only tiles of rectangular shape). Press SHIFT key and draw rectangle to define the
tile boundary manually. There are several ways of how to create set of multiple tiles. However, the first step
common to all of them is to define the Set data - for example the name, family, copyright, the storage folder,
characters encoding, etc. If your language uses special characters (other than used in English language),
make sure to select proper characters encoding, because routines for automatic labeling of map tiles use this
setting. Methods for tiles creation are:

1. The easiest method is to draw one large rectangle (covering for example whole state or country) and use
Automatic Split command from the pop-up menu that appears when you right-click on map in the list. This
command splits large rectangle into number of small rectangles according to density of population. It also
assigns names to most rectangles (names are taken from included cities, suburbs and villages). If there are
any rectangles located outside the area of interest (outside the country), you can select and delete them (to
reduce amount of downloaded data) or leave them as they are. 

2. More advanced (recommended) method is to use LassoLasso to draw irregular shape that includes the area of
interest. Then use Lasso>Generate TilesLasso>Generate Tiles command from the pop-up menu to create rectangular tiles that
cover selected area. Tiles generation is adaptive, like in approach 1. The difference is that you do not need to
delete tiles outside the area of interest. The lasso polygon does not need to be drawn very precisely. Usually,
you need to draw polygon with only few lines. Following pictures illustrate this method:

Draw polygon with lasso tool. Area of interest must lay inside of the polygon.
Polygon does not need to be very detailed.

Use pop-up menu > Lasso > Generate Tiles command.

Tiles cover the polygon area and they are generated
according to density of population (higher density=smaller tiles).

3. Another method is to draw one or several large rectangles and split them manually by setting the split point
and use of Split VerticallySplit Vertically or Split HorizontallySplit Horizontally command.

4. The most laborious method is to draw all small rectangles manually. Setting of appropriate grid can help to
align individual rectangles one to the another.

You can combine any of above methods to create such coverage of area of interest as needed. 

Controls LayoutControls Layout

11 Controls are organized to several tabs, according to their meaning. Use the "Set""Set" tab to define parameters
of whole map set like name, draw order, etc.

22 Controls on "Connection""Connection" tab allows to change internet addresses where program searches services
needed for maps downloading. Unless these services change their location, you do not need to modify
these data.
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33 Main menu allows to access commands for work with map set and individual tiles. Most of these commands
are also accessible via pop-up menu.

44 Area of individual tile (map) can be defined by depressing the SHIFT key and drawing rectangular bounding
box. 

55 Drawing of the tile bounding box respects the grid selected from this combo box. The grid helps to align
individual tiles one to another seamlessly. Grid lines are visible on the map preview if you zoom-in
sufficiently. 

66 Bounding coordinates of selected tile are displayed on this panel. Clicking left and right mouse button on
coordinate moves respective edge of tile. This can be used to adjust the size of the tile. Each move of the
tile edge is aligned to actually selected grid. You can change grid size anytime to adjust step of the
movement.

77 List of tiles in the set. When download starts, this panel displays download log instead.

88 The tile that is too large for processing is displayed with red color. You have to split such tile either
manually or automatically until it is small enough.

99 Tiles achieved by automatic splitting of large tile. Program splits parent tile according to density of
population and names the new tiles automatically. You can use Rename Rename command to change name of
each tile, if needed. These names appear in the map list of GPS.

1010 Selected tile. Cross of magenta color marks the split lines. If you decide to split selected tile manually, then
the parent tile splits along the split lines. To change position of the split lines, depress the ALT key and
click inside of selected tile. Split lines are aligned to selected grid.

1111 Coordinates of the split lines. Click on these coordinates moves split lines within the tile, using the grid lines
distance as a step for movement.

1212 Lasso marker can be used to define area of irregular shape. This area can be turned into tiles or used as a
mask for erasure of multiple tiles at once.

1313 When all tiles are drawn and the set is saved to disc, use DownloadDownload button to start download of the map
data. This process can last few seconds or several hours, according to map size and speed of your interner
connection.

Set ParametersSet Parameters

The SetSet tab contains all essentials parameters to define set of map. They include traffic side, maps
transparency, draw order, family ID., characters encoding (for languages with special characters) etc.

Object FilteringObject Filtering

Data downloaded from OpenStreetMap contain many objects which make map very detailed. However, too
much detail can make map large in size and hard to read, especially while driving. 'Include Objects' 'Include Objects' box on
the SetSet tab contains options to filter some objects from the map. Filtering makes resulting map in GPS
smaller and faster to render. Also, map is more legible. Typical objects that you might want to filter are
shapes of buildings, or icons like bus stops and road crossings. Option 'address' refers to icons with house
numbers and/or street name.

ResultResult

The final result is routable map in GPS, with turn-by-turn voice navigation. However, there are also some
other files created as well. Downloaded data are saved in Mapwel's MPW format (one MPW file for each Tile)
into chosen folder. This file format allows to edit map data in Mapwel. Optionally, MPW files are compiled into
the same number of IMG files compatible with Garmin GPS. This option is turned on by default. When
downloading is finished, user is asked whether individual IMG files should be merged together (and upload to
GPS right away) or not. If they are merged together, result is one overall IMG file that contains the whole
downloaded map set. It doesn't matter whether you upload individual IMG files or single overall IMG file to
GPS (individual files are merged together before actual uploading anyway).
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Routing (Turn-by-Turn Navigation)Routing (Turn-by-Turn Navigation)

Mapwel supports creation of routable maps with turn-by-turn voice
navigation. This feature is available only in the registered Advanced
version of Mapwel. 
Routable map uses special type of polylines called routable roads. To

create such polyline use the tool with  icon. This tool is intended for
manual drawing of the roads. However, the easiest way of how to make a
routable map is to convert vector map in OpenStreetMap (*.OSM)  or
cGPSmapper (*.MP) file format to the routable IMG file, which is
compatible with Garmin GPS units. 

Such conversion is very easy with Mapwel:  

1. Open *.OSM or *.MP file with main menu > File > Open command 
2. Upload it to GPS or save it to disc with use of main menu > File > Export Map command. 
3. There is also Convert OSM or MP file(s) to routable IMG fileConvert OSM or MP file(s) to routable IMG file command available from the main

menu > File. This command allows the batch conversion of multiple files at once and merges all
resulting maps into a single GMAPSUPP.IMG file. 

Nothing else is needed if you create single routable map. If you work with data from ESRI *.shp files,
please click here>>
. 

Turn-by-turn navigation with map created by Mapwel from the OpenStreetMap OSM file.Turn-by-turn navigation with map created by Mapwel from the OpenStreetMap OSM file.

More OptionsMore Options
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IntersectionsIntersections
Nodes where roads connect each other must be marked as
"Intersections" (red crosses on the right-side image). Otherwise,
Mapwel will not include them into the net of routable roads. If you
import map from *.OSM or *.MP file. the intersections are
detected automatically. If you use other files (like *.KML or
*.GPX), you have to mark the intersection nodes. There is a 
"Detect Intersections""Detect Intersections" command in the  main menu > Routing
that allows to mark all intersections at once. Also, there is a
manual method of marking the intersections - in the
editing/creation mode use the pop-up menu to mark the selected
node. This pop-up menu also allows to define turn restriction at
the node (see RestrictionsRestrictions below)

Border NodesBorder Nodes
To allow GPS to navigate between the separate maps when cursor reaches the border of the actual map,
the end nodes of map must be marked with "Border Node""Border Node" attribute. Use the same pop-up menu as in
above case to set the Border attribute of nodes. 

RestrictionsRestrictions

Mapwel allows to define road restrictions
(oneway road, toll road, access permission)
and node restrictions (left turn, right turn and
U turn restriction). These restrictions help the
GPS navigation engine to avoid restricted
places or directions. Roads with restrictions
are displayed in object inspector with icon or
multiple icons indicating the type of restriction
(picture at the left).

Road restrictions can be set in the Properties window, because
they are valid for whole road object. Node restrictions must be
set in the creation/editing mode which allows to access each
individual node. Use the pop-up menu to set required
restrictions at the selected node.  
Note: Roads can be drawn with use of straight line and curve
elements. Intersection attribute and node restrictions cannot be
defined for the middle point of the curve element. 

For correct coding of U turns, Mapwel needs to know the
driving side of roads in the respective country (map). Please
select the left-hand or right-hand traffic for the map you are
working on in the main menu > File > main menu > File > Properties window.
Default value is right-hand. 
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ParametersParameters

Just like any other vector object in Mapwel, road polylines
have adjustable parameters that are accessible in the
Properties window. The parameters specific for routing
purpose are: 

A A - "oneway" road attribute 

B B - "show direction" attribute - direction is added to the text
label of road when displayed on the GPS 

C C - "toll road" attribute - tool or fee must be paid to access
the road 

D D - access permission - from left to right: 1. emergency
vehicles, 2. delivery vehicles (up to 3.5 tonnes), 3. cars, 4.
public service vehicles (bus, taxi), 5. motorcycles, 6.
pedestrians, 7. bicycles, 8. trucks, lorries (over 3.5 tonnes) 

E E - max. speed 

F F - road class. Max. speed and road class define the road
hierarchy important for the optimum navigation. 

G G - type of polyline - defines how the road is rendered on the
GPS screen.

Street Names and House NumberingStreet Names and House Numbering

Roads can be assigned with parameters like city, zip code, state and country. GPS uses
this information for address searching. It is possible to use different values for the left
side and the right side of the road. Also, it is possible to define house numbering along
the road to allow GPS navigate to a specific house address. 
Use properties window to access the road parameters and select the "Address" "Address" tab.
Fill-in the Country, State, City and ZIP Code boxes. If you want to define house
numbers or separate data for the right-hand side of the road, check the "House"House
Numbering" checkboxNumbering" checkbox. This will enable access to another tab - "Numbering". "Numbering". Enter
the rest of address data into this tab. House numbering allows to use just odd, even or
all numbers. Define start and end number and type of numbering for respective side of
the road. If there are no houses on  respective side of the road, select "None" in the
numbers type combo box.

  TipsTips

• OSM files - these files often contain data like building shapes, sport areas, etc. Large number of these
objects can slow-down rendering of routable map and make it less legible while driving. If you want
to erase such objects from the map, please use main menu> Select > Areas > Type... main menu> Select > Areas > Type... function
to select required type of objects (buildings, for example) and then delete them all at once. 

• ESRI shapefiles - if you work with data from ESRI *.shp files, please click here>>. 
• When roads cross each other at a different height level (bridge or ramp), do not use intersection

attribute as the roads are not physically connected on this place. It is recommended to even not put a
node on such place to avoid possible automatic detection of intersection by Mapwel. 
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Limits of the current version Limits of the current version 

Export fromExport from
Mapwel into thisMapwel into this
formatformat

Import borderImport border
node attributenode attribute

ImportImport
multi-segmentmulti-segment
house numberinghouse numbering

ImportImport
single-segmentsingle-segment
house numberinghouse numbering

OSM fileOSM file NoNo NoNo NoNo NoNo

MP fileMP file YesYes YesYes NoNo YesYes

Import ofImport of
speed limitspeed limit

Import ofImport of
road classroad class

Import accessImport access
permissionpermission

ImportImport
onewayoneway
attributeattribute

Import turnImport turn
restrictionsrestrictions

OSM fileOSM file YesYes YesYes YesYes YesYes NoNo

MP fileMP file YesYes YesYes YesYes YesYes NoNo

  

OziExplorer filesOziExplorer files

Mapwel supports loading of OziExplorer *.MAP filesOziExplorer *.MAP files, which are files that contain information for
georeferencing of raster image. Link to the raster image is included in the *.MAP file too. Use main menu
> Image > Import OziExplorer Calibrated Image to import this raster image and georeference data. Image
is then automatically georeferenced and ready to create map from.

Georeference info in a *.MAP file includes map projectionprojection (a method of representing the earth's surface
on a plane), map datumdatum (a reference from which the measurements are made) and 2 or more
calibration pointscalibration points
.

Current version of Mapwel supports almost all datums supported by OziExplorer and it supports following
projections:

•  (UTM) Universal Transverse Mercator 
• (ITA1) Italy Grid Zone 1 
• (ITA2) Italy Grid Zone 2 
• (BNG) British National Grid(IG) Irish Grid 
• (SUI) Swiss Grid 
• (VICGRID) Victoria Australia 
• (VG94) VICGRID94 Victoria Australia 
• Lambert Conformal Conic
• Mercator 
• Transverse Mercator 
• (I) France Zone I 
• (II) France Zone II 
• (III) France Zone III 
• (IV) France Zone IV 
• (SG) Swedish Grid 
• Albers Equal Area 
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GeoTiff filesGeoTiff files

GeoTiff files are raster images in TIFF format with embedded georeference information like tie points,
transformation matrix, projection method and parameters, ellipsoid and datum code. Mapwel supports import
of GeoTiff images (use main menu > Image > Import GeoTiff Calibrated Image) and automatically calibrates
them with use of the georeference info. Imported data are in raster format and must vectorized, either 
automatically or manually, before sending to GPS.  

Current version of Mapwel supports about 50% of all datums defined by GeoTiff specification, including the
most frequently used WGS84, WGS72, NAD83 and NAD27. It also supports following projections methods:

• Mercator 
• Transverse Mercator 
• Universal Transverse Mercator (UTM) 
• Lambert Conic Conformal, 1 and 2 standard parallels 
• Oblique Mercator and Hotine Oblique Mercator 
• Oblique Stereographic 
• Albers Equal Area 

Exporting mapsExporting maps

This function can be accessed via main menu > File > Export Map. Use this command to save map in format
other than Mapwel's native MPW format if you need to process data in other software. Mapwel currently
supports data export into Garmin IMG, Google Earth KML and cGPSmapper MP formats.

Mapwel Advanced licence is need to use export function. It is not available in Mapwel Basic.

Google Earth KML (Keyhole Markup Language) formatGoogle Earth KML (Keyhole Markup Language) format

Maps exported into this format can be open in Google Earth and displayed on top of the earth surface. When
you create your own map, it is very useful to use this function to check accuracy of the map. If the 'terrain'
option in Google Earth is set, map is displayed so that it follows the terrain and it looks like 3D map.

  Map exported from Mapwel in KML format and loaded into Google Earth.
Map contains polygons, polylines and symbols.

POIs are exported with address info (if supplied).
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      Left: contour lines from Mapwel displayed 3D with 'Terrain' option in Google Earth.
Right: map from Mapwel displayed on top of the satellite image in Google Earth.

Garmin IMG formatGarmin IMG format

IMG is native binary format of Garmin GPS units. These files can be loaded into GPS with our freeware
MapUpload (included with Mapwel installation files) or with 3rd party upload software.

Mapwel (both Basic and Advanced) allows to load maps directly into the GPS. If you prefer to use other
uploading method, please note that Garmin GPS units with files 'visible' from PC require all maps to be
merged into single IMG files with name GMAPSUPP.IMG. Find out more here.

To define irregular shape of map, use the 'Background Area' polygon object in Mapwel. Please note that map
can contain only 1 object of this type and all other object must lie within its boundaries. If 'Background Area' is
used, GPS does not display objects outside of this polygon.

IMG File FeatureIMG File Feature AvailabilityAvailability

Irregular map shape

POI addresses, Country and State info support

User defined zoom levels

User defined polygons, polylines and symbols

User defined copyright text

Locking maps with unlock code

Routing

Marine maps

Custom (User Defined) ProjectionCustom (User Defined) Projection

Mapwel supports hundreds of projections and datums. If you need to use custom projection, please use
following approach:

1. Open Userprj.INIUserprj.INI file from your Mapwel>SettingsMapwel>Settings folder in any text editor. 
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2. Edit parameters in either [USER_DEFINED_Transverse_Mercator][USER_DEFINED_Transverse_Mercator] or
[USER_DEFINED_Lambert_Conformal_Conic][USER_DEFINED_Lambert_Conformal_Conic] section, according to the projection method. Then
save the edited file. Please note: change only fields at right side of '=', i.e. the key values. Do not
change section and key names. 

3. When using below window for entering coordinates, check the ProjectionProjection check box and select
X_User_Defined_Transverse_MercatorX_User_Defined_Transverse_Mercator or X_User_Defined_Lambert_Conformal_ConicX_User_Defined_Lambert_Conformal_Conic
projectionprojection. 

Current version of Mapwel supports transverse Mercator and Lambert conformal conic projections. Support
for other projections will be added in the future.

How to erase all maps in GPSHow to erase all maps in GPS

Use the main menu > GPS > Erase Maps is GPS command. 

How to erase specific maps in GPSHow to erase specific maps in GPS

Use the main menu > GPS > Erase Specific Maps command to open window with list of maps to be erased.
The list is empty when window opens. 

Click on Get Map List from GPSGet Map List from GPS button to download list of maps from the GPS. 

Click on Get Map List from IMG fileGet Map List from IMG file button to load list of maps stored in the IMG file on PC. IMG file can
contain single map or map set with many maps. Users can build and edit their map set on PC and then load it
to multiple GPS units. Use this option to erase specific maps from your map set file on PC, without need to
work with GPS. Mark maps to be erased by clicking on the respective line of the EraseErase column. 

When finished, click on button to perform erasure. All maps marked by X sign will be erased. This operation
may last even several minutes. 

How to compile multiple maps into IMG format at onceHow to compile multiple maps into IMG format at once

Use the main menu > Tools > Batch Conversion command. 

How to create map of irregular shapeHow to create map of irregular shape

If you want to make map of irregular shape, in order to not cover surrounding areas when displayed on a
GPS, place special area of Background AreaBackground Area type as a first object in the map. This area is displayed in pink
color in both 'Color' and 'Grey Scale' display modes. There must be only one area of this type in the map. If
there are more background areas in the map, map will be partially or entirely invisible in the GPS.
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How to define your own area, line and symbol stylesHow to define your own area, line and symbol styles

Use the main menu > Objects > User Defined Styles command to launch the editor of above mentioned
styles. 

How to measure track lengthHow to measure track length

The total length of all selected line objects is displayed in Properties window on the Line Tab. 

How to change serial data transfer speedHow to change serial data transfer speed

Use the main menu > Edit > Preferences command or change the speed in the Map Transfer window. 

Morphing of Image Morphing of Image 

This tool is intended for use with maps with unknown projection and datum, or with distorted maps. In other
cases, please try direct calibrationdirect calibration first.
When drawing vector map with use of scanned paper map and tracks acquired with GPS, you can often
encounter the problem of paper map not matching the tracks, even if it was declared as a 'GPS map'. In such
case another problem pops-out and this is how to draw the rest of objects as it is not clear how to position
them with respect to the measured tracks. If whole image is just shifted, you can use main menu
/Image/Move function to position the image under vector tracks properly. If deviation between image and
vector parts is not constant, correction requires more labour.
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 Fig. 1. Measured tracks do not match scanned paper map very well (left).
Image after non-linear calibration with three pairs of points (right).

Mapwel provides 'Image MorphingImage Morphing' tool for non-linear calibration of bitmap image to allow user to adjust
image before actually drawing vector objects on top of it. Morphing function uses pairs of points defined by
user. Image is calibrated so that area around the first point of each pair is transformed into area around the
second point of each pair. Click on main menu / Image / Image Morphingmain menu / Image / Image Morphing to start image adjustment.

The first pair of calibration points will appear on the screen. They are one of top of the other. Click on the
cross indicating position of the point and move it aside. Now you can see both points in the pair and an arrow
between them, which indicates direction of image transformation in this place.

     
  

   Fig. 2. Pair of calibration points.

If you click right mouse button on any of the calibration points, a pop-up menu appears, which contains
following command: Preview, Original, Add Pair, Delete Pair, Morph Image, CancelPreview, Original, Add Pair, Delete Pair, Morph Image, Cancel.
Place calibration pair on some corresponding places (fig. 3. left) and use the PreviewPreview command from pop-up
menu to see effect of calibration (fig. 3. right). First point of the pair is placed on street on the raster image.
Second point is placed on the corresponding place of the measured track. In PreviewPreview, area near first point is
transformed into area near second point and raster image matches the measured tracks much better.
We use PreviewPreview for now, because there will be more calibration pairs added. As adjustment is performed on
a raster image, each change could add distortion to the image. Therefore, use Preview to see effect of
calibration until all pairs are added. We will use Morph ImageMorph Image to perform all changes at once at the end of
calibration.
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   Fig. 3. Image with single pair of calibration points before calibration (left) and after calibration (right).

 Now we will add second pair of calibration points to calibrate upper part of the image. Use Add PairAdd Pair
command from the pop-up menu. Notice that image returns to original form to allow user to place all points
under the same conditions. Use PreviewPreview command to see calibration with two pairs. You can switch
between OriginalOriginal and PreviewPreview mode to examine points placement and calibration effect.

     

   Fig. 4. Image with two pairs of calibration points before calibration (left) and after calibration (right).

Measured tracks fit adjusted image quite good now, except the bottom part of the image. There has to be one
more calibration pair added. 
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Usually, there should be not many calibration pairs used, and they should be not placed one near to the other,
because influence of each pair reaches only to the nearest pair. If pairs are too near one to the other, image
gets distorted because of adjustments being too local.

       

     Fig. 5. Image with two pairs of calibration points before calibration (left) and after calibration (right).

Notice that roads near 3rd pair are calibrated even when the pair
is not placed on any particular object on the image (left).

Use such approach to prevent pairs being too near one to the other.

The image seems to be calibrated quite well with three pairs of points. So far we were using the PreviewPreview
mode. Now click on Morph ImageMorph Image function to perform all adjustments to raster image at once. 

When doing a large map, calibrate it part-by-part, each part with use of several pairs (like shown in above
example). Do not calibrate the whole map at once as each pair slows down the calibration process. As the
influence of pairs is more or less local, there is no reason to calibrate large map at once. 

Move ImageMove Image

When drawing vector map with use of scanned paper map and tracks acquired with GPS, you can often
encounter the problem of paper map not matching the tracks, even if it was declared as a 'GPS map'. If the
whole image is just shifted, the main menu / Image/ Move function can be used to position the image under
the vector tracks properly. In other cases, please click here for more image editing and calibration tools
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  Fig. 1. Image under the vector objects needs to be shifted.

Let's suppose that deviation is constant in this case. Click on main menu / Image/ Movemain menu / Image/ Move command to start
image adjustment. Place pair of points to mark the current and desired position of any spot on the raster
image. 

 Fig. 2. Current and desired position of spot on raster image. The shift direction is marked by an arrow.

  Click right mouse button to access a pop-up menu. Select Move Move to shift the raster image. 

  Fig. 3. Image shifted to fit under the vector objects. 

Manual map preparation for iQue, Nьvi, Zьmo, Oregon andManual map preparation for iQue, Nьvi, Zьmo, Oregon and
ColoradoColorado

All above units store detail maps on a memory card or in the internal memory. All detail maps, normally
stored as a separate img files, must be merged into a single file with GMAPSUPP.IMG name. Otherwise, GPS
will not recognize and display the maps. 

Mapwel Advanced allows to generate separate img files and then merge them into a single GMAPSUPP.IMG
file for use with iQue, Nüvi, Zümo, Colorado, Oregon and Dakota.
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Please follow these steps to create GMAPSUPP.IMG file:Please follow these steps to create GMAPSUPP.IMG file:

Step 1Step 1. Generate separate img files with Mapwel Advanced. Use main menu > File > Export Mapmain menu > File > Export Map to save
each map with img extension.

Step 2Step 2. Use Mapwel main menu > Tools > Merge IMG Filesmain menu > Tools > Merge IMG Files to merge your img files into a single file and
store it with GMAPSUPP.IMG name. If you want to upload maps to iQue, proceed to step 3. If you want to
upload maps to other GPS, proceed to step 4.

Step 3 (iQue only)Step 3 (iQue only). Use synchronization software included with your iQue (ActiveSync®, HotSync® or
other) to load finished GMAPSUPP.IMG file into GARMIN folder* of iQue memory card. Restart iQue to enable
uploaded maps.

Step 4 (Nüvi, Zümo, Colorado, Oregon, Dakota)Step 4 (Nüvi, Zümo, Colorado, Oregon, Dakota). Connect GPS to your PC and switch it on. Use Windows
Explorer or any file manager software to copy your GMAPSUPP.IMG file to GARMIN folder* in the GPS. Then
disconnect the USB cable and wait until GPS reads the maps.

*Check where your GPS stores detail maps (GMAPSUPP.IMG file) and load your file into this directory. The
previous GMAPSUPP.IMG file will be overwritten. If you want to preserve maps in this file, merge it to your
maps like any other img file (see step 2), prior to loading your maps to the card. 

Step 2 is discussed in more detail bellow:

Step 2 - Creation of GMAPSUPP.IMG FileStep 2 - Creation of GMAPSUPP.IMG File

Use Mapwel Advanced main menu > Tools > Merge IMG Filesmain menu > Tools > Merge IMG Files function to open window for merging
separate img files into a single file. Click right mouse button on the tab and use Add Map command from the
pop-up menu to add respective img files to the list.
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You can save list of img files on disc, for a future use. Use List > Save ListList > Save List command to store list into
Mapwel *.mml file.

When finished, click  button to generate single GMAPSUPP.IMG file from the list. Then upload this file to
the GPS as described in steps 3 and 4 above.

Mapwel with GPSmap 276CMapwel with GPSmap 276C

Default settings of this GPS units may cause that custom map uploaded from Mapwel is not visible. 
First of all, check the firmware version of your 276C. It should be 5.2 or higher. If you have older firmware,
please upgrade it with use of upgrader on the official Garmin web site. 

To make map visible, please follow these steps:

Make sure that the memory card is plugged into the GPS. Upload custom map from Mapwel to the GPS. Then
use MENUMENU button on the GPS to access this menu: 

Select Map InformationMap Information
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 If check box for Mapwel map is clear, check it. Quit the settings page (QUITQUIT button). Now use MENUMENU button
again. 

Select Set Up MapSet Up Map

. 

Set DetailDetail to MostMost. Also, make sure that Map OutlinesMap Outlines option on the next tab (MapMap) is turned on. 
This procedure should make your custom map visible on the GPSmap 276C. If problem with visibility persists,
please read further tips in the Troubleshooting chapter. 
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ControlsControls

Main WindowMain Window

11 The Tool Bar contains tools for creation, editing and transformation of objects.

22 Work AreaWork Area. When starting a new map, the work area is blank. User can import scanned image or
photo into the background of work area. Default colors of work area and grid lines are specified and
can be changed in Edit / Preferences.

33 Display Mode TabsDisplay Mode Tabs. In User mode, all objects (background image and map objects) are displayed
in user colors. In Image mode only the background image is displayed. In Vector mode only the
map objects are displayed (in user colors). Grey Scale mode simulates the monochrome display of
GPS units and Color mode simulates the color display of GPS units. Use the last two modes to see
how the map will look in GPS.

44 Button barButton bar. The most used functions from main menu and pop-up menus are accessible through
these buttons. 

55 Palette of ColorsPalette of Colors. Click right mouse button on any color to adjust this color. To change color of an
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existing object, press left mouse button on color and drag and drop it on the object icon in Objects
Inspector window or on the selected object in the work area. To set color that will be used for
newly created objects click left mouse button on any color. Color that will be used for new objects is
outlined in black and white.

66 Object Inspector window.Object Inspector window. All objects created on working
area are displayed here in order of creation. It shows order of
objects, their type, visibility, name and comment. 
When composing complex map with many objects, it is
sometimes difficult to isolate desired object in the work area.
Use Object Inspector in this case. To change order of objects,
select them with right mouse button, drag them to their new
position, and release mouse button. To Hide/Show object click
the eye icon to the left of each object. 
To access menu to duplicate, delete, or change properties, click
right mouse button on selected objects in Object Inspector
window. 
To change color of object in Object Inspector, press left mouse
button on any color in Palette and drag it to this object. Then
release the button. Another way is to double click the object icon
to access the color dialog box, or use the Color command from
the pop-up menu.
Color can be also dragged and dropped from object in the list
onto the palette.
To select non-contiguous subset of objects, depress the Ctrl key
and left click on each object.

In the editing mode the Object Inspector and Part Inspector
windows are replaced with basic parameters of the object. 

Read more about Object Inspector here.
  

77 Part Inspector window.Part Inspector window. Openings (holes) of area objects are displayed here as well as parts of
grouped objects. This window serves to select holes and parts for further manipulation, because
they cannot be selected in work area and in Objects Inspector.

88 Magnifying window.Magnifying window. This window displays enlarged area around mouse cursor. It aids precise
placement of nodes, allowing user to maintain view of design in the Work Area. To hide this
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window, use View/Zoom Window; this will enlarge the Parts Inspector window. When cursor moves
over Object Inspector, this window displays enlarged object icon and description.

99 Rulers.Rulers. Press left button on vertical or horizontal ruler and drag mouse to Work Area to create a
Guide Line.

1010 Status Bar.Status Bar. The mouse cursor coordinates, zoom and tool hint or other information are displayed
here.

1111 Button for sending the map into the GPSsending the map into the GPS unit. Same command is available in main menu / File.

1212 Main MenMain Menu. 

1313 Find Object controlFind Object control. Type several characters of searched object name or comment into this box.
If object with name or comment that begins with these characters exists, Object Inspector scrolls
the list to make found object visible and selects it. 

1414 Zoom Levels PreviewZoom Levels Preview. Use this control to preview how map layers will be displayed in GPS at
various zoom levels. 

AA Snap NodesSnap Nodes options. Use these check boxes to define snapping of nodes to work area edges, guide
lines or other nodes. Snapping helps precise placement of nodes. Same options can be found in 
main menu / Nodes. 

BB
Edge ModeEdge Mode combo box - choose line or curve edge as default when creating new objects.  

CC
 Middle Point First Middle Point First check box - if checked, new curve element is created so that on first click,

line is created. On a second click line turns to a curve using the previous point (end of line) as
middle point of curve. If it is not checked, the curve is created on a first click, but the middle point
must be dragged to proper position. 

DD Curvature of the rectangleCurvature of the rectangle with rounded corners.

EE Basic parametersBasic parameters of the newly created object. More parameters can be accessed with use of
Objects / Properties menu after finishing the object.

Object InspectorObject Inspector

The main features of Object Inspector are described in Main Window chapter
. 
Right click on selected object or objects in Object Inspector to access a pop-up menu for operations with
selected objects. 
For meaning of GroupGroup and UngroupUngroup commands please see Main Menu / Objects chapter
. 
To select and manipulate openings or grouped objects, use the Part Inspector window beneath the Object
Inspector window. It is not possible to select these parts directly on the Work Area. 
To change order of objects in Object Inspector, select an object with a left click, depress the right mouse
button and drag it to its new position in the list. Then release the right button and, from the menu that
appears, choose whether the selection should be placed BeforeBefore or After the item After the item. You can choose also
the Set Identical ParametersSet Identical Parameters command to copy properties from one object to another of the same type.
Double click on the object name to open the Properties window. 
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1 2 3 4 5 List item in the Inspector window 

Zo
om
Lev
el 

Name 
&

Commen
t 

1. Eye icon for showing/hiding object, 2. Small picture of object,
3. Type of object, 4. Name and comment of object.

Object is visible. Left click on the icon to hide the object.

Object is invisible. Left click on the icon to show the object.

Object Icon.

Object is Area.

Object is Area of type that is always displayed behind other
objects.

Object is Line.

Object is land or depth contour (Line).

Object is  railroad (Line).

Object is river (Line).

Object is trail (Line).
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Object is Line of road type.

Object is Line of road type, with a road sign.

Object is Point of Interest (POI) with empty address fields.

Object is Point of Interest (POI) with address.

Object is City.

Object is Map Feature.

Object is Exit.

Object is Opening in the Area. Openings are displayed in the
Parts window.

Object is composed of several other objects that are grouped.

Name 
&

Commen
t

Name and comment of object. Click on it to change object
properties.

A2
0

km
Automatic zoom level of object.

20
km Individually set zoom level of object.

ToolsTools

 From top to bottom: 
- Select and Transform Tool 
- Edit Edges Tool 
- Zoom Tool
- Zoom 1 Tool
- Pan Tool 

- Create Area Tool
- Create Opening Tool
- Create Line Tool 
- Create Point of Interest (POI) Tool 
- Create City Tool 
- Create Map Feature Tool 
- Create Exit Tool

- Create Routable Road
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- Create Marine Area *
- Create Marine Line *
- Create Marine Point *

- Create object with Freehand

- Trace tool (tool for vectorization of raster images)

* Tools available only in the Mapwel versions that support marine charts. 

Use zoom tool zoom tool to zoom in (left mouse button click) or zoom out (right mouse button click). If you want to
zoom in a specific area, depress the left mouse button and drag mouse to make selection. Then release the
mouse button and selected area will be enlarged so that it fits on the screen. 

Opening can be used only after Area or previous  Opening object.  It does not appear in Object Inspector
window as a separate object and cannot be selected directly on the Work Area. To select the Opening object
for transformation, use the Part Inspector window. To add Opening to Area, the Area must be either selected
or it must be the last object in the Object Inspector list. 
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Main MenuMain Menu

FileFile

The first 6 commands are New, Open, Open Recent, Save, Save AsNew, Open, Open Recent, Save, Save As and MergeMerge
. 
OpenOpen and MergeMerge commands allow user to open map files in Mapwel MPW and other formats. Use MergeMerge
command to combine two or more maps. Note that background bitmap is discarded when merging maps.
Only the vector map objects are preserved. Current version of Mapwel supports these formats: 

File FormatFile Format ExtensiExtensi
onon

ReaRea
dd

WritWrit
ee CommentComment

Mapwel .MPW

ESRI Shape File .SHP

OpenStreetMap .OSM

These maps are available for free from 
http://www.openstreetmap.org/index.html. Use

Export tab to download osm file of browsed
area.

Google Earth
Keyhole Markup
Language

.KML Files exported in this format can be used with
Google Earth.

Zipped Keyhole Markup
Language .KMZ

Both KML and KMZ files can contain calibrated
raster image. To import such image into
Mapwel, please use main menu > Image >

GPS eXchange .GPX

cGPSmapper
GPSMapEdit .MP

Current version of Mapwel does not support
auto routing, streets numbering & marine

charts

MapDekode .DBX

OziExplorer Waypoint
File .WPT

OziExplorer Track File .PLT

Garmin GPS Database .GDB

Garmin .IMG
Mapwel Advanced version can export maps into
IMG format and/or upload IMG files into GPS.

Advanced version also supports routable maps.

Click here to find out more about the ESRI shape filesESRI shape files import.

Click here to find out more about the free OpenStreetMap *.OSM OpenStreetMap *.OSM files support.

Mapwel allows to load osm file and upload it to Garmin GPS, or export into any of supported formats (see
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above table).

Upload Map to GPS Upload Map to GPS converts the map data into proper GPS format and allows user to upload one or
several MPW and/or IMG map files into the GPS unit. This command is intended mainly for compilation and
uploading of current map from the work area of Mapwel into the GPS. There is also another similar
command Upload IMG Files to GPSUpload IMG Files to GPS available in the Tools menu. This command launches separate
application MapUpload for loading one or multiple IMG files to the GPS. IMG files are maps already
compiled into format compatible with Garmin GPS units.

Countries and CitiesCountries and Cities. This command is used to define table of countries, states, cities, zip codes and
their mutual links. This table is necessary for creation of Cities and POI (points of interest) objects.

Export MapExport Map. Use this command to export map into Garmin IMGIMG, Google Earth KMLKML or cGPSmapper MPMP
map file. This function works only in Advanced version of Mapwel. The GPS unit to which the registration is
bound must be connected and switched on. 

The last command is ExitExit, which follows the usual Windows convention prompting user to name the map
and choose a location.

ToolsTools

Commands in this menu allow access to separate tools for maps creation, processing and uploading. These
commands do not affect current map in the work area of Mapwel. They work mostly with files stored on disc.

Upload IMG File to GPSUpload IMG File to GPS launches the MapUpload.exe program, which allows user to upload one or several
IMG map files into the GPS unit. MapUpload does not perform any checking if IMG file is correct. This function
is intended to allow user to upload map files that he/she has created in other software. MapUpload also
allows user to wrap multiple IMG files into self-extracting .exe file. It is also possible to embed author's logo
and map set image, and optionally lock maps to a specific GPS ID number. However, protection method
currently used in MapUpload is not secure. MapUpload can be used with command line to avoid manual
insertion of img files into the list. Use command (in a .bat file, for example) in form MapUpload.exe file1.img
file2.img file3.img to load multiple img files to MapUpload. Note: MapUpload.exe is a separate program that
can be found in the Mapwel folder. Unlike Mapwel itself, MapUpload is FREEWARE and it can be distributed
separately. It cannot be sold. 

Download Free Maps.Download Free Maps. This command opens window with Downloader tool for downloading of large map set
from OpenStreetMap servers and its automatic conversion into routable maps. This tool works only if your
computer is connected to internet. It is supposed to be used with Advanced version of Mapwel. Maps
downloaded with unregistered or Basic version of Mapwel are usable in GPS, but they are marked with 'Trial
Map' labels and they are not routable.

Merge IMG filesMerge IMG files. Use this command to merge several IMG maps into a single file. This command is useful if
you want to prepare maps for iQue, Nüvi, Zümo, Colorado, Dakota, Oregon  or Nüvifone manually. Otherwise,
Mapwel makes all map operations (transfer, add map, erase, erase specific map) and user does not need to
use this command.

Batch ConversionBatch Conversion. Use this command to access window for batch conversion of multiple MPWMPW, MP, GPX,MP, GPX,
KML, KMZ, KML, KMZ, OSMOSM or DBXDBX map files into the Garmin IMG format. First, select files to convert into the Map Files
Table. Then choose the destination folder for the IMG files and hit Compile button. List of source files can be
stored on disc with use of menu > List > Save command for later re-use. This function works only in
Advanced version of Mapwel.

Google > Launch Google MapsGoogle > Launch Google Maps. Use this command to compare your map created in Mapwel with satellite
image or Google map. It is useful when it is not clear what kind of object the data you are working from
represent. This command opens separate web browser window and launches Google Maps web site with
map, satellite or hybrid image of the area of your map created in Mapwel.

. 
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GPSGPS

Import Waypoints from GPS. Import Waypoints from GPS. Waypoints acquired by user can be used for map drawing. Import
waypoints from GPS and they become part of the map automatically. Please note that map (the "work
area" in Mapwel) is defined by North, West,  South and East boundary (coordinate). User can either import
only those waypoints, which coordinates fit into the map boundaries, or map boundaries can be adjusted
automatically so that all waypoints fit on the map. Use the first option when you add waypoints to an
existing map and you want to ignore the waypoints that are outside of map. Use the second option when
you work on a blank background and you want to import all waypoints from the GPS.

Import Tracks from GPSImport Tracks from GPS. Tracks acquired by user can be used for map drawing as well as the
waypoints.

Erase Maps in GPSErase Maps in GPS. Use this function to delete all maps in the GPS. Base Map uploaded by manufacturer
is not erased.

Erase Specific MapsErase Specific Maps. Use this function to delete specific maps in the GPS or in the IMG file that contains
a map set (such file is usually named GMAPSUPP.IMG). Base Map uploaded by manufacturer to GPS is not
erased with this operation. Learn more about this function here.

Display GPS IDDisplay GPS ID. Use this function to find out the unique identification number of the GPS unit defined by
manufacturer. 

EditEdit

Use the PreferencesPreferences command to change the map and data transfer settings. The work areawork area, nodesnodes,
edges, gridedges, grid and guide linesguide lines colors can also be changed under Preferences. Click here for more
information.

Snap to Guide LinesSnap to Guide Lines snaps selected objects to nearest guide line when user moves objects in the
Transformation mode. Objects are snapped only if they are near to the guide line. This function allows
user to align objects with use of the guide lines. It works with whole objects (not just edited nodes as snap
options under then main menu > Nodes). 

Lock Guide LinesLock Guide Lines disables editing of guide lines and adding of new guide lines. Locking of guide lines
prevents unwanted seizure of guide lines when working with digitized objects  in the work area.

Erase Guide Lines Erase Guide Lines deletes all guide lines in the work area.

CopyCopy and PastePaste are clipboard operations. 

ImageImage

ImportImport command is used to bring an image into the background as a template for drawing; Mapwel can
import an image in JPG, GIF, BMP, PNG and TIFF formats. Click here to learn about image size limit. 

Import OziExplorer Calibrated ImageImport OziExplorer Calibrated Image command imports OziExplorer *.MAP with raster image and
georeference information. Click here to learn more
. 
Import GeoTiff Calibrated ImageImport GeoTiff Calibrated Image command imports tiff raster images with embedded georeference
information. Click here to learn more
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Background FiltersBackground Filters and Edit Image WindowEdit Image Window are described separately.

Rotate to VerticalRotate to Vertical and Rotate to HorizontalRotate to Horizontal are tools for rotation of image. They are intended for precise
rotation of images that contain either vertical or horizontal lines (grid).  Place rotation marks on the object
(line) in the image and then click right mouse button on the work area. Select 'Rotate Image' from the pop-up
menu. Image will be rotated so that marked line is vertical or horizontal, respectively. Please note: use Edit
Image Window for rotation of image with angle parameter. 

CropCrop is tool for precise placement of crop marks and cropping of the image. Place crop marks on the image
and then click right mouse button on the 'scissors' symbol near the crop mark. Please note: Edit Image
Window can be used for cropping of image too. 

Straighten.Straighten. Use this tool to compensate distortion of scanned images or photos. If deformed image has
edges or grid that are supposed to be orthogonal, set the red marks on these deformed lines. Then click the
right mouse button on the work area and select 'Straighten Image' command from the pop-up menu. Image
will be transformed so that selected shape becomes a rectangle (see below image: blue shape transforms
into a black rectangle)

Image MorphingImage Morphing. Use this non-linear tool to stretch raster image to match measured tracks and waypoints.
 
MoveMove. Use this tool to move image under the vector map.

CalibrationCalibration. Use his tool to calibrate and georeference the image and the vector data drawn on top of the
image.

Delete ImageDelete Image if you want to reduce the size of the MPW file (for publishing map on the Internet, for
example) and you do no longer need the background image.

Export as BMPExport as BMP saves your cropped and adjusted image as a separate bitmap file. Use this function if you
need to use the image in other application. Mapwel stores map, image and all other data in a single MPW file.

Automatic VectorizationAutomatic Vectorization. Use this tool for quick creation of GPS map from raster image. 

Acquire (Scan) ...Acquire (Scan) ... command launches the image scanning software. This command work with scanners that
support TWAIN. Scanned image is transferred into background of the work area as if it was loaded with 
ImportImport command.

NodesNodes
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The Nodes Menu is accessible only in creation/editing mode.

Align Beginning to Previous ObjectAlign Beginning to Previous Object moves the beginning of an edited object to the end of previous
object. 

The next command, Align End to Next ObjectAlign End to Next Object, causes the end of the object being edited to the
beginning of the next object. 
Align Line Beginning to beginning of PreviousAlign Line Beginning to beginning of Previous. When doing a complex line, some line parts start not
on end of previous part, but on its beginning, instead. Use this function to place beginning of the new part
exactly on beginning of previous part.

Reverse NodeReverse Nodes Order changes the order of nodes. 

Use Delete Whole EdgeDelete Whole Edge command to erase whole edge and start its creation anew.

Snap nodes to Work Area EdgesSnap nodes to Work Area Edges, Snap to Guide LinesSnap to Guide Lines, Snap to NodesSnap to Nodes, Snap to Object EdgesSnap to Object Edges
are options for alignment of nodes during editing or creation of object.  Nodes are snapped only if they are
moved near to the work area edges, guide lines, other nodes or edges of other objects, respectively.
Please note: these options affect snapping of the edited nodes. Snap options under the main menu > Edit
affect snapping of the whole objects. 

ShapeShape

The Shape Menu is accessible only in the creation/editing mode. To use any of the 10 commands, place at
least one node in the work area, then select one of the shapes and draw it in the work area. Right mouse
click and select To ElementTo Elements from the small pop-up menu. Mapwel will move the last node to the nearest
point on the shape just created and the shape will be started from that point. This means the shape can
be started from any point. 

ObjectsObjects

EditEdit switches selected object to editing mode. 

GroupGroup is function for combining several objects into one for easier manipulations. This lets you apply the
same transformations, properties and other changes to all the objects within the group at the same time.

Use Ungroup Ungroup function to divide grouped objects. 

Sort ColorsSort Colors function changes order of selected objects so that objects of the same color are in the
successive order. 

Sort TypesSort Types changes order of selected objects so that Areas are listed first, Lines are next and then Points
of Interest, Exits, Cities and Map Features. This function helps you to organize objects in your map. 

Sort NamesSort Names function sorts selected objects alphabetically. 

Sort SizesSort Sizes function sorts selected objects according to their size. 

User Defined StylesUser Defined Styles command launches editor of filled areas, lines and symbols

PropertiesProperties command opens the window with properties of selected objects and map parameters.

Calculate Calculate item contains submenu with commands for calculation of of area and perimeter of selected
polygon(s) and length of selected line(s). 
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TransformTransform

Transformation WindowTransformation Window command opens window for alignment of 2 or more selected objects. This
command may be useful when drawing reference frames (circles) around some object 

Please note: use main menu > Convert > Create Circle around Point command for easier and more
precise drawing of reference circles. 

Combine OutlinesCombine Outlines makes single line object from series of lines. 

Expand ObjectsExpand Objects enlarges selected objects by offsetting the object contours. It is intended for creation of
overlay of constant width between adjacent objects. Expand Objects command does not provide the same
result as normal enlargement. 

Shrink ObjectsShrink Objects reduces size of selected objects by offsetting the object contours. Shrink Objects
command does not provide the same result as normal size reduction. 

ShapingShaping submenu contains commands for so called boolean operations on the filled areas. These
operations include union, intersectionunion, intersection and differencedifference. Click here for more information. 

ConvertConvert

The Convert commands work on objects selected with the Transform Tool (arrow) or in Objects
Inspector. 

Create Line from Area Create Line from Area creates line object from selected area object. If area object has openings,
program will create also lines from openings as a separate objects. 

Create Area from OpeningCreate Area from Opening creates a new area object from selected opening in an existing area.
Opening must be selected in the Parts Inspector window. This command is intended for situation when
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user needs to create object of other color for a hole (opening) in the area. User should adjust the newly
created area or the opening to make them overlay each other, to avoid gaps when displayed in the GPS. 

Create Area from LineCreate Area from Line creates a new area object from selected line object. If area is not closed,
program automatically closes it. 
It is important to note that above commands will duplicate an object and then convert the new object as
selected. Below commands just convert selected objects without duplication. 

Area to OpeningArea to Opening command can be used to convert areas like land or islands to openings in the
underlaying area like ocean, for example. Map may display faster in GPS if island is made as an opening in
the ocean area, letting the background (yellow) area showing through, as opposite to island being a land
area put on top of the solid ocean area. In the first case, GPS has lower number of layers to display. When
converting selected areas to openings, some area object must precede selected objects in the list, as
newly created openings cannot be a stand alone objects and they must follow after the area object. 

Map Feature to POIMap Feature to POI and POI to Map Feature POI to Map Feature convert respective type of points into the other type. 

Area to POIArea to POI can be used to convert small areas like buildings into the points of interest. 

Area to Transparent Grid CellArea to Transparent Grid Cell serves to create transparent grid from the polygons. This command
converts selected polygons to line objects with label in the centre of each cell. Label, in fact, is a point
without icon. Text is taken from the polygon's "name". 

Swap Object Name Swap Object Name and Comment command Comment command helps to manipulate objects in the list when using the Sort
objects on Name function. 

Create Circle around PointCreate Circle around Point creates "circles" of defined radius around all selected points. Near poles
very large "circles" look deformed (see below image), because of coordinate system projection. However,
real-world distance from center to any point on the "circle" is the same. 

SelectSelect

Commands in this menu allow to select vector objects with use of various criteria, or modify existing
selection. 

The first command is Zoom to Selected ObjectsZoom to Selected Objects. This command scrolls selected object(s) to center of the
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screen and zooms in or out to fit selection to the screen. It helps to localize object(s) selected in the Inspector
window in the work area. 

Next command Zoom and Edit Selected Objects Zoom and Edit Selected Objects works in the same way as above command, but it also
starts nodes editing mode. 

New Selection, Add to Selection New Selection, Add to Selection and Select Subset Select Subset options allow to define the way of how vector objects
are selected. 

Rest of the commands in this menu allows to select multiple objects of the same type (like Roads, POIs with
address) at once. They work with either whole map or just selection, according to selection mode defined by
above options. 

ViewView

Unlike the Eye icon Eye icon in the Object Inspector window which hides/shows only particular objects, commands
in the View Menu hide/show all objects that fit user-specified criteria.  

Areas, Lines, Points of Interest, Map Features, Cities, ExitsAreas, Lines, Points of Interest, Map Features, Cities, Exits settings show or hide respective type of
objects.

Area Captions, Line Captions, Symbol Captions Area Captions, Line Captions, Symbol Captions show or hide names (captions) of respective type of
objects in the work area. Symbols are all point objects (Points of Interest, Map Features, Cities, Exits).

Fill of AreasFill of Areas. Uncheck this setting to turn into the "wire frame" display mode. This is useful for example
when you need to make overlay of the Areas.

Show/HideShow/Hide Objects. Use this sub-menu to show and hide set of selected or unselected objects. 

Guide Lines, Button Bar, Grid, RulersGuide Lines, Button Bar, Grid, Rulers settings show or hide respective controls of the work area. 

Zoom WindowZoom Window shows/hides zoom window in the bottom right corner of the screen. Hiding this window is
useful in case of low screen resolution (800x600, for example) to enlarge Object Inspector window.

GPS Display FrameGPS Display Frame. Check this setting to show frame of the GPS unit display in the 'gray scale' and 'color'
modes. This function allows you to see if map does not have too much detail and if it will be legible on the
GPS display. To change size of the display frame, click on the GPS icon in the upper-left corner with right
mouse button.

Nighttime, Marine ColorsNighttime, Marine Colors. Use these settings to change the map colors in 'gray scale' and 'color' display
mode. Marine colors works in both 'gray scale' and 'color' display mode. Nighttime has effect only in the
'color' mode.
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RoutingRouting

Show IntersectionsShow Intersections switches on/off displaying of small icons on intersections, i.e. nodes where routable
roads intersect one another.

Split Self-Intersecting RoadsSplit Self-Intersecting Roads function divides roads which form closed loop into several parts.
Self-intersecting roads are not allowed in routable maps. When Mapwel compiles routable map, it calls
this function internally, so it is not necessary to use it unless you want to export routable map into file for
processing in other software. 

Detect IntersectionsDetect Intersections is function for automatic marking of road intersections. Maps created from OSM
and routable MP files should not need to mark intersections, because intersections are imported from
these files. Use this function if you draw routable map manually or if you import data from vector files
(like ESRI shapefiles) which do not contain node definition. Intersections can be marked also manually
node-by-node in the creation/editing mode when user has access to individual nodes of object.

Locate Unused IntersectionsLocate Unused Intersections command identifies nodes that are declared as intersections, but they are
used by only one road, i.e. they are not real intersections of two or more roads. Found nodes are
highlighted in the work area. This command helps to discover errors in the routable map.

Clear Unused IntersectionsClear Unused Intersections command deletes "intersection" flag from nodes that are used by only one
road, i.e. they are not real intersections of two or more roads. 

Merge Close Intersections. Merge Close Intersections. Data structure of routable maps uses approximately 0.00002 grid. Nodes
that are closer than this grid spacing are regarded as identical. Adjustment of node coordinates to this grid
is made automatically during map compilation. However, if you export map to *.MP or another file format
for processing in other software, it may be necessary to use this command to avoid too close nodes.

Freehand ToolFreehand Tool

Freehand toolFreehand tool works like a painting tool. Unlike the other Mapwel tools, which are based on the precise
manual placement of the nodes, curves and lines, Freehand tool allows to draw many of the Mapwel
objects with a free hand. Strokes are automatically converted to a chosen style. After conversion, strokes
can be edited as other vector objects (node by node). The Freehand tool can be combined with any other
tools in the Mapwel. Like other creation tools in Mapwel, Freehand tool can be used with various display
modes (User, Grayscale, Color). 
Freehand tool can work with any Microsoft Windows compatible mouse or digitizing tablet. Its use is not
restricted to any specific brand of tablet. 

Before you start actual drawing with the Freehand tool, you should choose the style you want to use. Click
with right mouse button or corresponding tablet pen button depressed on the Freehand icon (in the Tool
Bar). Panel with freehand styles will appear (picture below). This panel can be invoked also by holding the
left mouse button or tablet pen tip depressed about 1 second on the Freehand icon. Each style is
represented by its icon. Hover the cursor over the icon to display the style name. Select desired freehand
style to activate the tool. Mapwel will switch to creation/editing mode. 

 Freehand Styles  Freehand Styles 
1 Area
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2 Opening of Area or Marine Area 

3 Line/Road

4 Routable Road

5 Marine Area *

6 Marine Line *

* Styles available only in the Mapwel versions that support marine charts. 

Click left mouse button or tablet pen on the Freehand tool to start drawing. When the Freehand tool is active,
parameters of respective style are displayed on panel at the right side of the Mapwel window. After StrokeAfter Stroke
options allow to configure the Freehand tool. For example, it is possible to define whether to finish freehand
mode after a single stroke or reactivate the tool. 

Freehand OptionsFreehand Options

Meaning of the After StrokeAfter Stroke options is as follows: 

• Finish ObjectFinish Object - converts stroke into nodes and finishes creation/editing
immediately 

• Edit Edit - converts stroke into nodes and switches to normal nodes editing
mode 

• Another strokeAnother stroke - converts stroke into nodes and allows to add
another strokes. When finished, single vector object contains several
strokes.

 
Only one of above options can be active at once. If Reactivate tool is checked,
Mapwel automatically reactivates Freehand tool after each stroke. This feature
works only with Finish object option. To end strokes creation, hit ESC or ENTER
(RETURN) key on the keyboard, or click the STOP button above the freehand
options. 

User Defined StylesUser Defined Styles

Some Garmin GPS units support user defined styles* for filled areas, lines and points. Mapwel software
includes editor of these styles and library of predefined styles. Editor allows user to create her/his own fill
patterns, colors, line styles and point icons (cities, map features, points of interest and exits). New styles are
saved with map in Mapwel *.MPW format. 
* Support of user defined styles may require upgrade of the GPS firmware. User defined styles were
successfully tested on GPSmap 60C, 60CSx, Nuvi and Vista C. If map with user defined styles is loaded to
Garmin GPS that does not support them, objects are displayed with use of the GPS built-in styles, i.e. user
defined styles are not used. 

Warning:Warning: if you create map for loading into several types of GPS units, make sure that all of them support
user defined styles, before actual creation of the map! 
Assign different Map Set DataMap Set Data (main menu > File > Properties > ID tab) to all your maps if they contain user
defined styles. This ensures displaying of map with correct colors in the GPS. GPS uses the same color palette
for all maps in a map set. Therefore, maps with different palettes are not displayed correctly if they have the
same Map Set DataMap Set Data
. 
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User defined styles for filled area, line and point of interest.

It is also possible to save respective new styles as a separate files to disk, for future use in other maps, or to
export styles in *.txt format to use with other mapping software. 

Library of predefined styles.

 Editor of user styles can be accessed with Mapwel main menu > Objects > User Defined Stylesmain menu > Objects > User Defined Styles, or with
pop-up menu in the Properties window
. 
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Filled AreasFilled Areas

Editor of user styles contains separate tabs (1) for editing of areas, lines and points. User defined areas are
bitmaps of 32x32 pixels size. Only 2 colors (foreground and background) per pixel are allowed. User can
define one pair of colors for GPS daytime mode (13) and another pair for the nighttime mode (14). Use of the
background colors is optional. If they are not used, the area will be transparent. It is possible to define name
of the style (displayed by some GPS units) in up to 4 languages. Use table (15) to type-in the name of the
style. use right mouse button click on the Language column to choose from available languages. 
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Zoom level (16) control allows to define maximum zoom level at which the object using this style will be
visible in the GPS. 
Layer specifies order in which object will drawn by the GPS. By assignment of proper layers user can define
which object will be drawn on top of the other objects. 
Please see below table for description of the rest of the controls. 

11 Tabs with editors for areas, lines and points.

22 Editor zoom control. It is also possible to use mouse wheel to zoom the
work area in and out.

33 Open and Save buttons. Use these buttons (or menu>File) to open or save
styles from/to library.

44 Pencil tool.

55 Paint Bucket tool. 

66 Clear style button.

77 Scroll buttons.

88 Menu.

99 Work area.

Mapwel 2010 7.1 Manual

88



1010

Color palette. Some GPS units (GPSmap 60CSx, for example) use fixed
256-colors palette. Use default colors from this palette to ensure that your
styles will look the same on the PC and GPS. Use left and right mouse
button click to copy color from palette to Day colors controls. Use SHIFT,
CTRL or ALT + left and right mouse button click to copy color from palette
to Night colors controls. 

1111 Style preview in daytime colors.

1212 Style preview in nighttime colors.

1313 Daytime foreground and background colors. If Background check box is
unchecked, the area will be transparent.

1414 Nighttime foreground and background colors. If Background check box is
unchecked, the area will be transparent.

1515 Table with optional style names in various languages.

1616 Maximum zoom level for the style.

1717 Combo box with available user defined styles.

1818
Layer (see above). Use left and right mouse button click on the number to
increase/decrease the value. Click on the caption to use other ways of
inserting the value.

LinesLines

Lines editor is available on the second tab. Line styles are defined as either the bitmap of 32 pixels width and
variable height, or line with set pen and border width. In both cases, line uses only two colors, which can be
defined separately for the daytime and nighttime modes. 
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Please see below table for description of the rest of the controls. 

11 Pen and Border width for lines that are not defined by bitmap.

22

Use Bitmap control for switching on/off the bitmap mode. When displayed
on the GPS, bitmap is rendered with either horizontal or vertical sampling
(according to angle of the line), unless the Diagonal Sampling is enabled. In
such case, rendering uses also the diagonal sampling, but it does not look
good for all bitmaps.

33
Height of the bitmap. Use left and right mouse button click on the number
to increase/decrease the value. Click on the icon to use other ways of
inserting the value.

PointsPoints

Unlike areas and lines that use only 2 color bitmaps, point styles use multicolored icons with optional
transparent background. Point icons are of variable size (up to 24x24 pixels), with up to 255 colors. Use left
mouse button when drawing the icon to fill pixels with color choosen from the palette. Use right mouse button
to erase pixels (transparent background). See next chapter (Menu) for useful command that help with
drawing of the icons. 

Please note: Left mouse click on the palette selects the drawing color. Right click opens the color mixer that
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allows to define a new color. However, some GPS units (GPSmap 60CSx, for example) use fixed 256-colors
palette and they are not capable of displaying more colors. In such case, all colors are mapped to the default
palette. 

Please see below table for description of the rest of the controls. 

11 Preview of icon on various backgrounds.

22 Control to enable/disable nighttime icon.

33 Controls to switch beween editing of daytime and nighttime icon.

44
Width and Height of the bitmap. Use left and right mouse button click on the
number to increase/decrease the value. Click on the icon to use other ways
of inserting the value.

MenuMenu

Menu > Edit Menu > Edit contains some useful commands that make creation of the styles easier: 

Derive Night Colors from the Day ColorsDerive Night Colors from the Day Colors command generates automatic night colors for edited area or
line style. 
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Replace Colors with Closest Matching Colors in the PaletteReplace Colors with Closest Matching Colors in the Palette command replaces all colors in edited style
with the most similar colors from the palette. 

Add BorderAdd Border command creates thin border of selected color around the point icon (see above castle icon
example). 

Copy Daytime Icon to Nighttime IconCopy Daytime Icon to Nighttime Icon and Copy Nighttime Icon to Daytime IconCopy Nighttime Icon to Daytime Icon commands create
copy of the respective icon. 

Create Nighttime Icon from Daytime IconCreate Nighttime Icon from Daytime Icon command generates the nighttime icon, which is a darker copy
of the daytime icon. 

Use menu>File>Save Whole Set menu>File>Save Whole Set and menu>File>Open Whole Setmenu>File>Open Whole Set commands to copy all styles from
one map to another if you want them to use the same set of styles. 

Edit Mode Pop-Up MenuEdit Mode Pop-Up Menu

 Click right mouse button in creation/edit mode on the work area to access this pop-up menu.

Finish ObjectFinish Object ends the creation/edit mode. If object is Area, program automatically closes the object.

Close EdgesClose Edges closes the object. Use it for land and depth contour lines to ensure that line is closed.

Split ObjectSplit Object. This command is available only for Line objects. Select square node (end of curve or straight
line element) and use this command to split the object.

Insert, Delete, to Curve Insert, Delete, to Curve and to Lineto Line commands are available only if rectangular node is selected (end of
curve or straight line element). Insert creates a new element before the selected element. Delete erases
selected element. To Curve converts selected straight line element into curve. To Line converts selected curve
element to straight line.

Use Place Start Point HerePlace Start Point Here command to change beginning of the object. This command is available only if
rectangular node is selected (end of curve or straight line element).
Mapwel automatically places the name label of Area object. If you want to assign position of label manually,
use the Place Name Label Here Place Name Label Here command. The label center is positioned on a place where the mouse
cursor was before you invoke this pop-up menu (small cross on the below picture). Note: Label position is
valid only in the Mapwel. It is not transferred into the GPS. GPS decides where to display name labels by itself.
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Snap to Nearest NodeSnap to Nearest Node moves selected node to nearest node which belongs to other object (not to currently
edited object). 

PreferencesPreferences

The Preferences window is accessible through main menu under Edit / PreferencesEdit / Preferences. The map and data
transfer settings as well as the work area and grid settings can be changed in this window. Choosing SaveSave
and Applyand Apply means these parameters will be loaded automatically for each new map. 

Edit Mode ColorsEdit Mode Colors allow user to define colors of edges and nodes used in edit mode.

If Max. Contrast Max. Contrast is checked, edge and node colors are darkened or brightened according to the edited object
background. Max. Contrast can make edited objects more visible. 

Note: the Grid ColorGrid Color can be set also in Image/Adjust individually for current design. It is saved with file and it
overrides the default grid color from Preferences. 

Map Export Map Export parameters: 

If map is TransparentTransparent, it is uploaded into the GPS without the background area and it overlays the GPS base
map or other maps located on the same position, letting the underneath maps show through. Use this setting
if you want to add details to an existing map in the GPS. 
Please note: many line objects are displayed in a different way if the map is transparent. Use the displaydisplay
mode Tabsmode Tabs
 to check the look of your map after setting it to transparent mode. Mapwel does not show underneath maps,
because they are in GPS, not in Mapwel. 

Precision / Data SizePrecision / Data Size. If map is drawn with use of curves, this control allows user to set to how many lines
the curves are converted when map is uploaded into GPS (as the GPS accepts only the lines). Mapwel
provides curves for easier drawing of map and  for precision control. Once the map is drawn in curves, user
can adjust the size of data according to available memory in GPS. 

Characters EncodingCharacters Encoding. This option allows to display special characters (like chinese, slavic ...) on the GPS by
setting an appropriate characters codepage to the map. Technical note: only ANSI characters which codes fit
into single byte are supported. Unicode is not supported. 

Transfer SpeedTransfer Speed. Use this control to set speed of the map upload. If you encounter problems with loading
maps into GPS, decrease the transfer speed. This parameter affects only the serial data transfer. Speed of
USB data transfer is set automatically. 
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Trace ToolTrace Tool

Trace ToolTrace Tool lets you create vector objects from raster images. This process is almost (though not entirely)
automatic. Trace tool allows to vectorize one object (or set of similar objects) at once, but it cannot
vectorize whole map with different types of objects at once. Tracing should be repeated for respective
types of objects (filled areas, roads, rivers, etc.). Trace tools works on images with any common color
depth (including True Color and bi-tone) that are sufficiently clean. 

Raster image should be imported into work area with use of main menu>Image>Import command. 

Vectorization involves several steps (please see animated Fig.1): 

1. Activation of the trace tool, choosing of the proper trace style (see Fig.2).
2. Setting of magic wand tolerance, selection options and vector object properties.
3. Selection of respective object or multiple objects on raster image with magic wand.
4. Setting of vector objects parameters (type of line, zoom level, etc.)
5. Conversion of selected raster objects into vector objects. 

Fig. 1. Animation - Use of the Trace Tool

Before you start using the Trace tool, you should choose the style you want to use. Click with right mouse
button on the Trace tool icon (in the Tool Bar). Panel with trace styles will appear (picture below). This
panel can be invoked also by holding the left mouse button depressed about 1 second on the Trace tool
icon. 

Each style is represented by its icon. Hover the cursor over the icon to display the style name. Select
desired style to activate the tool. Mapwel will switch to creation/editing mode. 

  Fig. 2. Trace Tool styles (styles 4-6 are not available in the current version of Mapwel). 

Trace Styles Trace Styles 
1 Area

2 Line/Road

3 Routable Road

4 Marine Area *

5 Marine Line *

* Styles available only in the Mapwel versions that support marine charts.

Trace ControlsTrace Controls
 
Use these controls to adjust: 

• Parameters of vector objects 
• Magic wand sensitivity (tolerance) 
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• Selection operations for selecting multiple objects 

Color boxColor box - define color of vector objects. "Auto Color" must be unchecked. 

Auto ColorAuto Color - color of vector objects will be taken from raster image. 

Simplicity Simplicity - varies in range 0..10. 0 means precise vector objects with high
number of elements. 10 means low precision and low number of elements. 

Edge TypeEdge Type combo box - select curve (polycurve) or straight lines (polyline) type
of vector objects 

Ignore OpeningsIgnore Openings - valid only for filled areas. Holes in vectorized areas are
ignored, only the outer shape is vectorized. 

SelectionSelection - various operations for selection of multiple or complex objects. Use
"Add Similar" if you want to select non-contiguous objects of similar color at
once. 

Background Image FiltersBackground Image Filters

Background filters affect the way the background (imported image) is displayed behind the drawn vector
objects. Characteristics such as Brightness, Contrast, GammaBrightness, Contrast, Gamma and colors SaturationSaturation can be adjusted, as
well as the grid color.

In contrast to graphics programs where the main meaning of filters is to enhance the look of an image, filters
in Mapwel are intended for dimming, darkening, brightening or other adjustment of image so that its colors do
not interfere with objects drawn on top of the background image. All these parameters are saved with map
into a single MPW file.

The grid colorgrid color in this window does not affect the default grid color in Preferences that is used when starting
a new map.

Gamma Gamma 
parameter changes brightness mostly of dark colors and it does not affect absolute black and white. 
All above settings do not affect the map appearance in the GPS. They serve to make map drawing more
comfortable. 

Shortcut KeysShortcut Keys

33 Place beginning of object to end of previous object

ee Add new line part to edge

dd Add new curve part to edge

spacespace Finish object creation/editing, if possible

escesc Cancel object creation/editing

arrow keysarrow keys Scrolls Work Area
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arrow keys +ALTarrow keys +ALT Moves selected objects in transform mode and selected node in edit/create mode.

-- Zoom out

++ Zoom in

Page UpPage Up Zoom out

Page DownPage Down Zoom in

SHIFT+SHIFT+
Page UpPage Up To Front (order of objects)

SHIFT+SHIFT+
Page DownPage Down To Back (order of objects)

CTRLCTRL
When depressed, forces new lines and curves to precise horizontal, vertical or
diagonal direction in edit/create mode. If used with Shapes, creates precise circle
instead of ellipse and square instead of rectangle.

CTRL+1CTRL+1 Zoom to selected object(s)

CTRL+2CTRL+2 Zoom to selected object(s) and start nodes editing mode.

CTRL+ACTRL+A Select all objects (in transformations mode)

Shift+CTRL+AShift+CTRL+A Deselect (in transformations mode)

CTRL+CCTRL+C Copy selected objects into clipboard

CTRL+DCTRL+D Duplicates selected objects

CTRL+ECTRL+E Edit selected object. If more objects are selected, the first of them is edited.

CTRL+ICTRL+I Import image

CTRL+NCTRL+N New document (map)

CTRL+SCTRL+S Save file

CTRL+VCTRL+V Paste objects from clipboard

CTRL+YCTRL+Y Redo

CTRL+ZCTRL+Z Undo

DeleteDelete Deletes selected objects (in transformations mode). Deletes an element that ends
with selected square (in edit/create mode).

INSERTINSERT Inserts a new element before selected square node in edit/create mode.

CTRL+ALT+BCTRL+ALT+B Background Filters (Image brightness and colors)

CTRL+ALT+ICTRL+ALT+I Display Edit Image window

ALT + mouseALT + mouse
cursor move cursor move 

Pan work area without having to switch tools. Cursor must move near edges of the
work area.

ALT+AALT+A Hide / Show Map Features objects

ALT+DALT+D Hide / Show grid
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ALT+EALT+E Hide / Show Exit objects

ALT+FALT+F Hide / Show Area objects

ALT+GALT+G Hide / Show guide lines

ALT+IALT+I Hide / Show City objects

ALT+OALT+O Hide / Show Line objects

ALT+PALT+P Hide / Show Points of Interest

ALT+RALT+R Hide / Show rulers

ALT+TALT+T Hide / Show button bar

ALT+ZALT+Z Hide / Show zoom window

Double click onDouble click on
Work AreaWork Area

The new object  is started immediately without need to select any tool. The new
object is of the same type as the last object.

CTRL+F1CTRL+F1 Align beginning of object to end of previous object (in editing mode)

CTRL+F2CTRL+F2 Align end of object to beginning of next object (in editing mode)

CTRL+F3CTRL+F3 Align beginning of Line object to beginning of previous Line object (in editing
mode)

CTRL+F5CTRL+F5 * Set/Clear selected node(s) attribute "Intersection" 

CTRL+F6CTRL+F6 * Set/Clear selected node(s) attribute "Border node"

CTRL+F7CTRL+F7 * Set/Clear selected node(s) attribute "No left turn"

CTRL+F8CTRL+F8 * Set/Clear selected node(s) attribute "No right turn"

CTRL+F9CTRL+F9 * Set/Clear selected node(s) attribute "No U turn"

CTRL+SHIFT+F7CTRL+SHIFT+F7 * Set/Clear selected node(s) attribute "No left turn (opposite direction)"

CTRL+SHIFT+F8CTRL+SHIFT+F8 * Set/Clear selected node(s) attribute "No right turn (opposite direction)"

CTRL+SHIFT+F8CTRL+SHIFT+F8 * Set/Clear selected node(s) attribute "No U turn (opposite direction)"

CTRL+SHIFT+F10CTRL+SHIFT+F10 * Clear all restrictions of selected node(s)

CTRL+ALT+OCTRL+ALT+O Create Line from Area

TABTAB

When creating new object, TAB key can be used to quick adjustment of  the curve
elements. Create new curve element with TAB key instead of left mouse button.
Then move the mouse with TAB key depressed to adjust the curve. Then release
the TAB key. 
Please note: to use the TAB key for curves adjustment, the edge mode must be

set to 'curve'.  

x x Works like right mouse button. It is intended for use with tablet.

* applies to routable roads only. 
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Edit Image WindowEdit Image Window

Click here for more image editing and calibration tools.
 
The Edit Image WindowEdit Image Window is accessible through main menu under Image / Edit Image Window. While Edit
Image window is visible, four small rectangles appear in the work area to allow user to crop the image. 

Rotate image first. Usually, the scanned image is not perfectly horizontal or vertical. Press left or right mouse
button on the red angle parameter or click the rotate icon to adjust the angle. 
Second step is setting of crop lines. Press left mouse button on any of four small rectangles and drag them to
a new position. Area outside of selection will be cropped. 

Please note: to rotate or crop image precisely, use main menu / Image / Rotate to Vertical, Rotate to
Horizontal and Crop tools. After above steps, click ApplyApply to perform changes. 

Guide LinesGuide Lines

Animated image

Guide Lines are horizontal, vertical, or slanted lines that can be placed anywhere in
the work area window to aid in object placement and nodes alignment.  

To create a new guide line, position cursor on either vertical or horizontal ruler,
depress the left mouse button and drag cursor to the work area.

Guide lines can be used for areas and lines splitting. Place the guide line on the
object. Select object and then select the guide line. Click right mouse button on the
guide line to access pop-up menu. Choose Slice Selected Objects command.

Use main menu > Edit to lock or erase guide lines or to switch on/off snapping of
objects to the guide lines. Use main menu > Nodes to switch on/off snapping of
nodes to the guide lines. 

Countries and Cities TableCountries and Cities Table

Access this table either via main menu > File or click Countries and Cities button in the Properties window. 
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Countries and Cities TableCountries and Cities Table is used for City and POI (point of interest) objects. If you want to use CityCity
objectsobjects in your map, you should fill this table first. City objects with undefined name are not transferred into
the GPS. 

If you use POI objectsPOI objects in your map, you need to fill this table only if you want to use country, state, city or zip
code fields in the POI address. Any field in the POI address can be left empty. 
To fill Countries and Cities Table follow these steps: 

1. Enter countries and their codes (codes are optional) into the first table. To add new a line, press the
F2 key on your keyboard. To delete last line in the table, hit F3 key on your keyboard. 

2. If Country has states, enter states and their codes (codes are optional). 
3. Assign respective country to each state. Click right mouse button on the 3rd column in the States

table to access pop-up menu with countries list. 
4. Enter cities. 
5. Assign respective country or state to cities. Click right mouse button on the 2nd column in the Cities

table to access pop-up menu with countries and states list. Countries are marked with a blue square
and States are marked with a red square. 

6. Enter ZIP codes 
7. Assign respective city to ZIP codes. Click right mouse button on the 2nd column in the ZIP Codes table

to access pop-up menu with cities list. 

Main menu in this window contains following commands: 

TableTable. Use it to save save and openopen Countries and Cities Table. If several maps use the same table, you can save
the table and open it in another map. 

ImportImport command allows to load countries, states, cities or zip codes from separate text (*.TXT) files. TXT
file must have following format: 

Item1/Code1
Item2/Code2
Item3/Code3
... 

"/Code" section optional and it is valid only for countries and states (for example: Great Britain/GB). TXT files
with cities and zip codes should not have "/Code" section. 

EditEdit. Use it to add or delete last line in the table. 

Erase.Erase. Use it to erase tables in this window. 
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SortSort. Use it to sort tables in this window alphabetically. If the are objects in the map which are already using
Countries and Cities table, they are automatically adjusted. 

Valid charactersValid characters

Country, State, CityCountry, State, City - letters and - & ' / 
Country and State CodeCountry and State Code - letters
Zip CodeZip Code - letters and digits 
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ObjectsObjects

Object TypesObject Types

Area Object Area Object 

Use Area Tool Area Tool  to create an area object. The edge of the
area object is composed of straight lines and curves. Small
rectangles are end points of lines and curves. Small circles are
middle points of curves. The cross at the left side is beginning of
the edge. 

Area object can contain openings. Opening objects must be

created with Opening Tool and they must follow after the
main Area object. 

User can adjust properties of area object, like name, comment, zoom level and
type. 
Click with right mouse button on the object type to set individual zoom level for
object and/or edit user defined object style
. 
Areas are drawn in order determined by 'layer'. For example, 'Park' type objects
are drawn in layer 6, which means that they are draw behind areas in layers 1..5
and on top of areas in layers 7 and 8. Therefore, some area types are displayed
in the background, even if they were created on top of other areas. To make such
areas visible, you have to create openings in objects that are displayed in front of
them. 'Layer' is adjustable for user defined styles. 

The green object is the area that is displayed
behind others (park, in this example). We
need to make an opening in the surrounding
land to make park visible (it shows through the
opening). Notice that the two areas overlap.
This is very important, because GPS could
display tiny gap between the two areas,
otherwise.

Line Object Line Object 

Use Line ToolLine Tool  to create a line object. The edge of the line object is composed of
straight lines and curves. Small rectangles are end points of straight lines and curves.
Small circles are middle points of curves. The cross at the left side is beginning of the
edge. 
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Depending on the type, Line object can have: 

• Normal name label with optional comment. 
• Altitude or depth label. 
• Road label and any of the 6 road signs. Select the proper road sign in the 

SignSign combo box in Properties window. 

Use the Line Tab in Properties window to measure length of line objects. 

Symbols Symbols 
These objects display on the map mostly as an icon with name. If cursor is placed on top of the icon
(in GPS or in 'Grey scale' and 'Color' tabs in Mapwel), the optional comment is displayed as a hint.

Point of InterestPoint of Interest. This object can be assigned with address (house number, street, phone number,
city, zip code, state and country). If city, zip code, state and country are used, they must be chosen
from the already filled-in Countries and Cities table. Address is displayed in the GPS when you click on
the POI icon.

CityCity. The city name must be chosen from the already filled-in Countries and CitiesCountries and Cities tabel. City
cannot have comment.

Map FeatureMap Feature.

ExitExit.

Properties of ObjectsProperties of Objects

To change parameters of several objects at once, select objects, click right mouse button and select 'Properties'
command from the pop-up menu.  Properties are organized in several tabs, according to type of objects. 

Color Tab

Area Tab

Line Tab

Routable Road Tab

Map Feature Tab

City Tab

Point of Interest (POI) Tab

Exit Tab

Map Tab

Map Zoom Levels Tab

Map ID Tab
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General Routing Parameters

Color TabColor Tab

This tab is common for Areas and Lines. Symbols (Map
Features, Cities, POIs and Exits) do not have color
property. 
Use the color control to assign work color to the object.
Work colors are used only in the Normal and Vector display
mode. When transferred to the GPS, the work color
information is discarded. GPS uses its own colors according
to type of object (see Area and Line tabs). 
Work color can help you when you draw large and
complicated map. For example, you can assign different
colors to land contours according to their altitude. 

If you want to define custom colors and patterns that are
transferred to GPS with map, please use editor of
user-defined styles (main menu > Objects > User Defined
Styles).
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Area TabArea Tab
These parameters are applicable only to Area objects. All
these settings are uploaded with map into the GPS. 
Control marked with arrow 1 is Individual Zoom Level of
selected object(s). If set to AUTO, the global zoom level of
respective area type is used (in this case, zoom level of
'Park' type). Zoom Level defines maximum zoom in which
the object is displayed in GPS. 

Name is the text that is displayed on the area in the GPS.

Comment is text that is displayed when you place cursor on
top of the area. 

The list at the bottom contains available area types. Always
assign the proper type to the area object, because the area
type defines how the object is displayed in the GPS. Each
row in the list contains type name, color sample and gray
scale sample of the area. 
Color sample shows the area color and pattern if loaded
into GPS with color display. Grey scale sample shows the
area color and pattern if loaded into GPS with monochrome
display. 

Arrow 2 marks Global Zoom Level of areas of 'Park' type.
The global zoom level is used for each object of the same
type. unless the object has set an individual zoom level. To
set global zoom level for any area type, click right mouse
button on the area type and use the pop-up menu that
appears. 

The icon marked with arrow 3 indicates layer in which the
object of respective type is displayed. By proper
assignment of layers to the types you can achieve one type
of area objects to be displayed on top of (or under) the
other types. 
Objects in layers with higher index are displayed behind
areas with lower layer index, regardless of their creation
order (the 'Park', for example). To make such area visible,
you have to make openings to all areas that cover this
area. 

In this example, an opening was made to the yellow area
to allow the green area show through.
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Line Tab with road Line object

Line TabLine Tab

These parameters are applicable only to Line objects. All
these settings are uploaded with map into the GPS. Please
note: objects of this type are not routable, even if they are
roads. You have to use Routable Roads objects if you want
to use routing in GPS.

When accessed through pop-up menu / Properties (i.e. not
through editing mode), the total length of all selected line
objects is displayed in this tab. You can use it to measure
imported tracks, for example. To change distance units use
the Edit > Preferences window. 

Control marked with arrow 1 is Individual Zoom Level of
selected object(s). If set to AUTO, the global zoom level of
respective line type is used (in this case, zoom level of
'Road' type). Zoom Level defines maximum zoom in which
the object is displayed in GPS. 

 Setting of this check box defines whether to display the
direction indicator after the line name or not.   

Depending on the type, Line object can have: 

• Road label and any of the available 6 road signs
(roads). 

• Normal name label with optional comment. 
• Altitude or depth label (land and depth contours). 

Name is the text that is displayed next to the line or over
the line in the GPS. Comment is text that is displayed when
you place cursor on top of the line. 

Altitude or Depth label can contain only digits. You can
choose the elevation and depth units in the Edit >
Preferences window.  

Road label can contain both letters and digits. 

The list at the bottom contains available line types. Always
assign the proper type to the line object, because the line
type defines how the object is displayed in the GPS. Each
row in the list contains color icon and gray scale icon, line
style and the type name. Icons show the color (or several
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colors) used for displaying of this line type in the color and
monochrome GPS. 

Arrow 2 marks Global Zoom Level of lines of 'Road' type.
The global zoom level is used for each object of the same
type. unless the object has set an individual zoom level.

To set global zoom level for any line type, click right mouse
button on the line type and use the pop-up menu that
appears. 

   

Left: line tab with normal Line object.    Right: line tab with
elevation (depth) Line object
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Routable Road TabRoutable Road Tab

Polylines of this type allow to create routable map with
voice turn-by-turn navigation. Besides below mentioned
parameters it is possible to define house numbers along
the road. Click here to find out more>>more>>

A A - "oneway" road attribute 

B B - "show direction" attribute - direction is added to the
text label of road when displayed on the GPS 

C C - "toll road" attribute - tool or fee must be paid to access
the road 

D D - access permission - from left to right: 1. emergency
vehicles, 2. delivery vehicles (up to 3.5 tonnes), 3. cars, 4.
public service vehicles (bus, taxi), 5. motorcycles, 6.
pedestrians, 7. bicycles, 8. trucks, lorries (over 3.5 tonnes) 

E E - max. speed 

F F - road class. Max. speed and road class define the road
hierarchy important for the optimum navigation. 

G G - type of polyline - defines how the road is rendered on
the GPS screen.

There are two special road types: Roundabout and Ramp
for which GPS generates a special navigation instructions.
Mapwel identifies these road types automatically when
importing map from OSM file. It is also possible to convert
road to any of these types manually with use of the
Properties window.
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Map Feature TabMap Feature Tab

These parameters are applicable only to Map Feature
objects. All these settings are uploaded with map into the
GPS. 

Meaning of controls marked by arrow 1 and 2 is the same
as on the area or line tab. 

Map Feature Name is the text that is displayed next to the
object icon in the GPS.

Comment is text that is displayed when you place cursor on
top of the icon. 

Coordinate controls allow you to change the object
position. To change position format, use the main menu 
Edit > Preferences
. 
The list in the middle is the Map Feature Class. Some
classes have several subclasses that are displayed in the
bottom list. Choose the proper Map Feature type using the
class and subclass lists. 

Icons in the class and subclass lists show how the Map
Feature will look like in the color GPS (left icon) and
monochrome GPS (right icon). 
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City TabCity Tab

These parameters are applicable only to City objects. All
these settings are uploaded with map into the GPS. 

City is the text that is displayed next to the object icon in
the GPS. User is not allowed to type the city name directly
into this box. It is necessary to fill the Countries and Cities
table first (click on the button at the bottom). Then it is
possible to choose city from drop-down list in this combo
box. 

Please note: City objects with undefined name are not
uploaded into the GPS. 

Coordinate controls allow you to change the object
position. To change position format, use the main menu 
Edit > Preferences
. 
Meaning of controls marked by arrow 1 and 2 is the same
as on the area or line tab. 

The list in the middle is the City Type. 

Icons in the type list show how the City will look like in the
color GPS (left icon) and monochrome GPS (right icon). 
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Point of Interest (POI) TabPoint of Interest (POI) Tab

These parameters are applicable only to POI objects. All
these settings are uploaded with map into the GPS. 

POI Name is the text that is displayed next to the object
icon in the GPS.

Comment is text that is displayed when you place cursor on
top of the icon. 

Coordinate controls allow you to change the object
position. To change position format, use the main menu 
Edit > Preferences
. 
Meaning of controls marked by arrow 1 and 2 is the same
as on the area or line tab. 

The list in the middle is the POI Class. Some classes have
several subclasses that are displayed in the bottom list.
Choose the proper POI type using the class and subclass
lists. 

Icons in the class and subclass lists show how the POI will
look like in the color GPS (left icon) and monochrome GPS
(right icon). A few monochrome icons looks different in the
Garmin® Rino™ GPS. These icons are marked with *. 
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POI can have addresses assigned. User can fill any of the
address boxes or left them empty.  

House, Street and Phone data can be typed directly. 

Country, State, City and ZIP Code are available from the 
Countries and Cities Table, which must be filled first (click
on the button at the bottom). 

Address is displayed in the GPS when you click on the POI
icon. The address format can be defined in the Map Tab
(see below). 

Valid characters:

• House - letters and digits.
• Street - only letters.
• Phone - digits and - sign. 
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Exit TabExit Tab

These parameters are applicable only to Exit objects. All
these settings are uploaded with map into the GPS. 

Exit Name is the text that is displayed next to the object
icon in the GPS.

Comment is text that is displayed when you place cursor on
top of the icon. 

Coordinate controls allow you to change the object
position. To change position format, use the main menu 
Edit > Preferences
. 
Meaning of controls marked by arrow 1 and 2 is the same
as on the area or line tab. 

The list in the middle is the Exit Class. Some classes have
several subclasses that are displayed in the bottom list.
Choose the proper Exit type using the class and subclass
lists. 

Icons in the class and subclass lists show how the Exit will
look like in the color GPS (left icon) and monochrome GPS
(right icon). 
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Map TabMap Tab

These parameters apply for the whole map. 

Map Name is the text displayed in GPS as a name of the
map 

Map Coordinates define the coordinates of bottom (south),
top (north), left (west) and right (east) edge of the map. 
To change coordinates format, use the main menu Edit >
Preferences.

Address Format defines mutual position of house, street,
city and zip code data fields in the Points of Interest
address (see the POI Tab above) as it is displayed in the
GPS.

Map Draw Priority affects order in which overlapping maps
are displayed on the GPS. Map with higher Draw Priority is
drawn on top of the overlapping map with lower Draw
Priority, unless the second map is transparent. Transparent
maps are always drawn on top of the non-transparent
maps, even if they have lower Draw Priority.

User Defined Styles check box allows to switch on/off
saving of the user defined styles into the map file when
exporting map into IMG file or uploading map to GPS. It
does not affect the storage of user styles in source *.MPW
file. 
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Map Zoom Levels TabMap Zoom Levels Tab

These settings apply for the whole map. 

Map uploaded into GPS has several layers (zoom levels).
Each zoom level contains different amount of data to
speed-up map displaying and to prevent too many objects
being displayed in higher zoom. Default settings are
intended for detailed custom map of relativelly small scale.
You do not need to change them (very much) unless you
create map of large scale, for example map of the whole
continent or world map. 

Controls on this tab allow user to define number of zoom
levels and approximate zoom by which map layers appear
on the GPS display. 

The number of objects visible in respective zoom level is
displayed at the right side of the check box. 

In zoom level 0 all objects are visible. The higher is the
zoom level, the lower is the number of visible objects. Use
controls in above parameter tabs if you want to make some
individual object or all objects of the same type more
visible or less visible. When you define zoom level of
individual object (POI, for example) zoom level 6 means
that object will be coded into all available layers from layer
0 up to layer 6, which is visible at zoom 30km or closer. 

Upper layers contain less objects coded with lower
accuracy for fast and legible rendering of maps in GPS.
GPS does not render all layers at the same time - it
chooses the one closest to the current zoom. Each layer is
coded with 2 times lower accuracy than below layer.

For detailed maps the most important layer is layer 0, with
best possible accuracy 2.54 m. This layer, however,
requires lot of memory space because it contains all
objects and coordinates are coded with best accuracy. 

Most of custom maps can use default zoom levels. In some
cases it may be useful to redefine one or two levels to
optimize appearing layers as you zoom in because GPS
uses slightly more complicate logic to choose which layer is
displayed at which zoom. For example, layer 6 does not
necessarily appear at zoom 30 km. On some maps it can
appear one step above or below 30 km zoom. 

Best Possible AccuracyBest Possible Accuracy informs you about accuracy
available for the current map scope (map coordinates
range) when uploaded map to the GPS. Internal data
structures of GPS use coordinates grid that limits
coordinate accuracy to this value.
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Map ID TabMap ID Tab

These settings apply for the whole map. 

Each map contains ID number, which should be unique
among maps that are present in the single GPS unit at the
same time. 
Mapwel generates internal map ID automatically from map
coordinates and creation time. 
This tab allows to define map ID manually and/or set the
map ID as a filename for export of map into the IMG and
MP format, which can be useful if you want to use map in
other software programs. 

Copyright text is coded in the map file and it is usually
displayed during the GPS start-up or in Map Information
menu. Each GPS type may display the copyright text in
other way. 

Map Set DataMap Set Data

allow user to define set to which the map belongs. If two
maps belong to different map sets, they are listed as a
separate items in the Map Information menu in GPS. This
allows user to switch on/off individual map sets in GPS.
Sub-region ID does not affect the map set definition. It is
reserved for future use. 

Map Set DataMap Set Data also affect the way of how user-defined
colors and styles are used by GPS. Maps within the map set
share the same user defined styles, i.e. all maps with same
Map Set Data are displayed with same colors and patterns.
Assign different Map Set Data Map Set Data to all your maps if they
contain user defined styles. This ensures displaying of map
with correct colors in the GPS. 

These settings are supposed to be used only by an expert
user. If you upload your maps directly into GPS with
Mapwel or MapUpload, you do not need to change default
values. 

 General Routing Parameters General Routing Parameters

TrafficTraffic defines the driving side. Setting of this parameter
affects coding of U-turn restrictions.
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Transformation of ObjectsTransformation of Objects

Select object with use of Transform Tool  and: 
To change size proportionally, left click any corner square and drag to desired
size. 
To change size non-proportionally, left click a middle square and drag to
desired size. 

 
There are 2 ways of how to make selection of objects with marquee box: 

1. Drag marquee box from left to right to select objects without completely enclosing them with a marquee
box 

2. Draw marquee box from right to left to select only those objects that lie completely within the marquee
box. 

ShapingShaping

These commands work on objects selected with the Transform Tool (arrow) or in Objects Inspector. 
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The main menu > Transform > Shaping commands allow to modify and combine selected objects with use of
the boolean operations. 

Two selected objects. Green object has an opening.

Union - this command creates an object or objects that contain all selected objects merged together. Vertices
inside of the filled areas are erased. If selected objects do not overlap one another, result of the union are
copies of the original objects.

Union of two objects.

Intersection - this command creates an object or several objects that are intersections of the selected objects.
If selected objects do not overlap one another, this function does not produce any new object (as intersection
does not exist).

 Intersection of two objects.

Difference - this command subtracts selected objects from the object that is first in order of creation among
the selected objects. It is necessary to arrange order of respective objects in the object inspector list before
use of this function, to assure proper order of objects. Newly created object or objects contain only those
areas of the first object that are not covered by the next objects. 

Difference of two objects. 
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